Support

Open search

HW-Q90R Disconnects!

Highlighted
SOLVED
Apprentice

Took delivery of this brand new product on Saturday only to find I'm one of many reporting that it has a fundamental problem. 

 

It disconnects from the Sub and both Rear speakers when it's turned off. Power cycling the Sub and the Rears will reconnect them but this is unacceptable in a product costing £1500.

 

Samsung, please respond and let us know that you're aware of this (unbelievable if you're not) and what action is necessary to make this product function correctly. Either a firmware update or an acknowledgement that we might have a faulty batch and require replacements. 

 

See this link for how widespread this has already become: 

 

https://www.avforums.com/threads/samsung-hw-q90r-soundbar-review-comments.2231672/

 

Please  respond. 

 

 

417 REPLIES 417
Highlighted

I have the same issue... darn! firmware updated to the latest on 1010.5. The subwoofer (most of the time) intermittently disconnected - what can be done to fix this issue?

Highlighted

Guys i have an issue.

Just got the soundbar, and the sub does not want to connect.

It has the quick blue led flashing, if i press the ID Set button it does not do anything, the red led does not come up.

I tried pairing sub does not pair. When i power on the red blinks 3 times then comes the quick blue blinking.

The satellites are pairing.

I have the following firmwares

M 0128.0 B 1010.5 H 0051.0 FD 0040.0 W 0240.0 S 0000.0 RR 0136.0 RL 0136.0

Highlighted

Turn off the system, power down and un-plug everything, wait a minute. Re-plug everything, then do an ID set using your remote. I don't remember which button it was, but there are two ID set mechanisms, one when the system is in standby and one when it's on. The former normally works for me.

 

Remember to fully power cycle all satellites and the sub when you do this.

 

Depending on your sub, it might continue to slowly blink blue - tip it towards the soundbar to make it connect. After that it will reconnect automatically.

 

If you have a 5ghz WiFi active, be sure to set it to a lower channel, non-DFS (still not confirmed but it helped me).

Highlighted

always the same problem with the subwoofer and rear speakers! no connection when soundbar is put ON ...

firmware is updated with SmartThings with most recent version 1010.5, all other steps executed (ID setup, etc.)

can't check firmware codes, as when holding the SoundMode button for +6 sec the test mode starts ...

 

I am already tired to re-do all the setup steps to make it work and do not understand SAMSUNG not solving this problem as it seems there are many many others ...

Highlighted

in addition: Netflix Dolby Atmos Sound is not available anymore ... another bug after new Firmware installed!

until now some movies and series on Netflix were available in DolbyAtmos sound, this feature is not available anymore, as the Soundsystem  is not compatible! same is with Xbox Sound settings. 

Anyone can help?

Highlighted

Anyone figure out how to keep the soundbar connected to Bluetooth? Mine keeps dropping out when playing music from my phone. For as expensive as this unit is I can't believe the support and quality is this bad. Wow what a mistake I made. 

Highlighted

Netlix Dolby Atmos just works fine here after the update..

Strange...

Highlighted
Nice....so the solution is to do this every day.....for the rest of ownership of this faulty device.
Highlighted
Haha yeah exactly.
Highlighted

.

Top Liked Authors