Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

HW-Q800C cannot do the Firmware Update?

(Topic created on: 19-02-2024 12:47 AM)
778 Views
MarkB1
Journeyman
Options

Hi Guys, I just purchased the HW-Q800C Soundbar and noticed its at Firmware V1002 . So I wanted to upgrade it to the latest V1004 but I'm having some issues. The USB is formated to FAT32 and I have extracted the two files as the user guide says - so I have just 2 files in the root of the USB. Plugged the USB into the service port and turned on the soundbar. 

All I get on the display is "D.IN" for  few seconds, then it turns off and nothing else displayed? I left it for 10 minutes just in case but no more displayed?

Its should just start automatically updating -right? Don't need to tell it to look at the service port or anything?

Checked the USB and its MBR and FAT32 - and has both files in the root. So where an I going wrong - please help!

 

1 Solution


Accepted Solutions
Solution
MarkB1
Journeyman
Options

Hi there, replying to my own post as I think its done it!  Not sure what got it to go, but I formated the USB fully (not just a 'Quick Format'). Then i unplugged the soundbar from the power for 30 seconds - insert the USB and plugged power back in. After about 20 seconds it displayed UPDATE  - UPS. It did this for about 1 minute the 'D.IN' and then 'WiFi' then 'LATEST VERSION'? Nothing like what the upgrade notes said would be displayed?

I left it for a further 10 minutes just to be sure.  Unplugged the USB and its all done at V1004!!

I would say I believe the way forward is to unplug the soundbar, as it must hold some data in standby and stop the upgrade happening. I hope this helps others out there having the same issue

 

View solution in context

0 Likes
8 REPLIES 8
Solution
MarkB1
Journeyman
Options

Hi there, replying to my own post as I think its done it!  Not sure what got it to go, but I formated the USB fully (not just a 'Quick Format'). Then i unplugged the soundbar from the power for 30 seconds - insert the USB and plugged power back in. After about 20 seconds it displayed UPDATE  - UPS. It did this for about 1 minute the 'D.IN' and then 'WiFi' then 'LATEST VERSION'? Nothing like what the upgrade notes said would be displayed?

I left it for a further 10 minutes just to be sure.  Unplugged the USB and its all done at V1004!!

I would say I believe the way forward is to unplug the soundbar, as it must hold some data in standby and stop the upgrade happening. I hope this helps others out there having the same issue

 

0 Likes
Steve1914
First Poster
Options

Hi I did this update on my Q800C yesterday to version 1004 and now when on SmartThings app checking the update option my sound bar says no data does yours do this 

0 Likes
MarkB1
Journeyman
Options

Hi Steve, I just checked mine. It goes off to check, then comes back with the message “No Updates available”.
Mine is at v1004.0 and that should be the latest, so I don’t expect it’s gone up. The only way to be sure Steve is just go to the Samsung website and see if there is a newer version - if so update! If I seen an update actually work with the app then I’d have a bit more confidence and faith with it.

0 Likes
MarkB1
Journeyman
Options

Hi Steve, I just re-read your question. When you say it says no data, do you mean the page is blank? Mine says the version it’s at with a button to check for updates.

if it does not have ANY detail or show the v1004.0, I’d question if the update worked?

that being the case, do it all from start - Full format USB, download off Samsung, power down soundbar, plug in USB, plug and power up the soundbar and wait!

0 Likes
MarkB1
Journeyman
Options

If the soundbar is displaying that message, I’d say do the update again! My soundbar looks fine, and during the update it came back with a scrolling message saying “firmware updated”

0 Likes
Steve1914
First Poster
Options

Hi 

I downloaded the latest software for the Q800c on to a usb stick 1004.0 and installed it and according to SmartThings my sound bar is showing 1004.0 which is correct. And when I did a check on SmartThings to check the software version again originally it said latest update. But I had to reset the bar and now when I check the software version on SmartThings it now shows on the bar as no data 

0 Likes
MarkB1
Journeyman
Options

Hi Steve, I don’t understand why you had to reset the bar after you’d done the update?

I just did the update, checked smart things to confirm it was at v1004 and that was it left it alone. 
A reset normally takes it back to factory settings and not sure if that includes a factory firmware level?

I would just do the update again, check on SmartThings after to see it’s at v1004 - then just use as normal

0 Likes
Steve1914
First Poster
Options

Just did a reset on the bar because I was having a few Dolby atmos issues with my Blu-ray player and since resetting it the display now says no data when checking the software version via SmartThings 

0 Likes