Support

Open search

Problem with audio passthrough

Navigator

Hi,

 

I've just bought an UE40MU6470 (U.K. model) and connectd to my Onkyo 7.2 reciever via HDMI ARC. I have enabled Anynet+ and selected Sound Output --> Reciever(HDMI).

HDMI Input Audio Format is Bitstream and Digital Audio Format is Dolby Digital.

 

Now here is my problem:

When I play/cast a video with DD 5.1 (from Netflix and others) my Onkyo reciever lights up the Dolby and that's good. When I play a video with DD+ 5.1 then my reciever thinks it's a PCM stream and only when I change the Digital Audio Format to Dolby Digital + I get my reciever to recognise the stream as DD+ 5.1 (which means audio passthrough is working?). If the video has DTS audio I have to change AGAIN the Digital Audio Format to DTS for my reciever to light up DTS.

 

WHY a 2017 UHD TV can not recognise automatically the audio stream and pass it to the reciever to do the decoding??

My 5 year old LG TV could do that.

 

PLEASE samsung can we get an "Auto" option in the Sound-->Expert Settings-->Digital Audio Format-->Auto 

This way the TV will automatically detect and passthrough the audio to the reciever without the need to MANUALLY change the Digital Audio Format setting.

 

Or am I missing something?? Please help!!

 

Vangeliis

9 REPLIES 9
Observer

Hi

I have the same problem with a 65 Inch mu7055 2017 tv. and a yamaha reciver. 
I also come from a LG tv with no problems.

Did you find a solution?

 

 

Navigator

@IL_OMEGA wrote:

Hi

I have the same problem with a 65 Inch mu7055 2017 tv. and a yamaha reciver. 
I also come from a LG tv with no problems.

Did you find a solution?

 

 


Yes, I bought an Nvidia Shield TV and connected it as follows:

Shield TV—>Reciever—>TV (hdmi arc).

Black Belt 

@vangeliis wrote:

@IL_OMEGA wrote:

Hi

I have the same problem with a 65 Inch mu7055 2017 tv. and a yamaha reciver. 
I also come from a LG tv with no problems.

Did you find a solution?

 

 


Yes, I bought an Nvidia Shield TV and connected it as follows:

Shield TV—>Reciever—>TV (hdmi arc).


Its odd why modern TVs do not have a second hdmi for audio pass through like some bluray players,  as arc can not send raw HD audio like atmos or dtsx. 

I also have a shield TV and also use kodi as an excellent media player as it plays every format you throw at it.  Just remember you need to set it up in settings,  if using. 

Paul

New Member

Hi Vangelis. Just got a new Samsung and have simiilar issue. Did you find a solution? Thx 

Navigator

Hi there,

 

I bought an Nvidia Shield TV and connected it as follows:

Shield TV—>Reciever—>TV (hdmi arc). 

 

Black Friday is just around the corner....

First Poster

I have a similar problem. The only output option on my 55” Serie 6 TV is with optical cable. I just got some new bluetooth headphones and wanted to try them out. So I connected the optical cable out to an old Optical Converter to Analog and then from it to the 35mm out to a bluetooth transmitter. After everything connected and having the headphones paired with the transmitter, there was no sound, so I switch manually the audio settings on the TV to PCM and they worked great. 

My problem now is that the TV is not letting me choose back to my original (before optical cable setting) different than the PCM, as it is stocked at that option, even when I disconected the optical cable from the TV, resetting the TV to factory settings. It only lets me choose the audio output from TV speakers or Optical out, but on TV Speakers, I am only able to listen to the menu sounds but no audio from the video coming from the HDMI stream. The options in advance settings of Dolby and Dolby plus are blocked.

 

Even worst now, I just tried to chat with Samsung Help Support and the Agent hung up on me.

CarlH Moderator
Moderator

Hi @jjmoses21. Sorry to hear you were hung up on, this isn't what I like to hear. Did they advise anything before they did that or even attempt remote access to your TV? 

Voyager
is it on PCM still? it needs to be on bitstream. check that sound settings are not on global and change that to the other option. then each output source can be tested
First Poster

Problem resolved, but I had to change my configuration to work how Samsung wants.

 

I had only one HDMI cable connected to my TV. The out signal came from a switch where I had connected the Cable Box, my Apple TV, PS4, and another HDMI in, to connect Computer or iPad, so I would only have to choose the number of the source in the switch, and it would stream the signal out to the TV. That did not work, the only way to work was to pass through the wall with all the cables hanging out and have the TV connected directly to the source streaming. As soon as I connected the TV directly to the Cable Box, the option to have Sound without PCM came available.

 

It should not be like that.

 

Thanks for the replies.

Top Liked Authors