Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Samsung Health snore detection not working with Watch 4 classic and Galaxy Note 10

(Topic created on: 01-09-2021 02:05 PM)
smbougie
Journeyman
Options
Wearables

I just got a Watch 4 classic and almost everything works fine. It tracks my sleep and oxygen levels while sleeping, but the snore detection is not working. 

I have my phone plugged in and it is on a flat surface near my head. My watch knows I am sleeping, so why doesn't the snore detection work? I tried changing permissions, turned them all on for a couple nights even, but still it doesn't work. 

How close to my head does my phone need to be? Does it matter if it is a few inches lower than my head? Do I have to be facing it all night? Does the room need to be silent? Any suggestions on getting snore detection to work would be appreciated. Thanks!

 

edit: I plug in my phone and put it near my head when I sleep. I have it set to check for snoring every night. It works sometimes. One night I had tons of recordings, one night only 1, but mostly it is 0 because it doesn't work. I think it has something to do with where the phone is, how close to my head it is, because my watch/phone records my sleep just fine; if it knows I am asleep, it should be checking for snoring. 

Anyway, I am giving up on this. I know I snore and it should work and has worked, but it's unreliable. I'm just glad the oxygen levels record while sleeping, that's more important than snoring. 

55 REPLIES 55
Siebrand
Apprentice
Options
Wearables

Sorry, that was for Gerasimos Apostolato...

0 Likes
Higira
First Poster
Options
Wearables

Ah okay. No worries. Just received an email you replied so I just responded. My bad.

0 Likes
Siebrand
Apprentice
Options
Wearables

Perhaps the SH app permissions on your phone? You could try another app, e.g. SleepAsAndroid, to see if it is a phone issue or Samsung Health...

0 Likes
dstern
Journeyman
Options
Wearables

Same here, s20 ultra Galaxy Watch 4 classic, tried everything, everything working except snoring detection

0 Likes
Members_Pg3Mq9R
First Poster
Options
Wearables

Just a thought, under the Samsung Health app settings and App permissions on your phone is the Files and media set to allow ? on my phone it was in the Denied section (How can the snoring audio be saved if the app does not have the permission to access ?)

Maybe worth check on your App permissions.

0 Likes
BeefrmNYC
First Poster
Options
Wearables

Hi, I'm pretty late to the reply party as this post is several  months old. However, I thought I'd respond  just incase anyone else hasn't figure it out. In order for your samsung watch to record snoring;

1.First, turn on snore detection. In samsung  health app. It will prompt you with permission settings. click "always allow". 

2. Secondly  on your watch, there's  a setting you need to turn on every night before you go to bed and turn off every morning in order for the phone to start recording snoring . It's  called "sleep mode." If you swipe down on your watch from top to bottom, you should see the "sleep mode" button on the left-side of the "power button". It has a picture of a bed and Cresent moon. When you turn this on via watch, your cellphone screen will turn gray. This means sleep mode is activated and your phone is now recording .

20220323_185921.jpg

The phone screen will only turn gray if it's a capable  samsung phone. Be sure to turn it off once you've waken or you will miss phonecalls. Best

0 Likes
smbougie
Journeyman
Options
Wearables

I've had it work on occasion without using sleep mode. I might just give that a shot though, see if it can consistently work.

0 Likes
dstern
Journeyman
Options
Wearables

Works only if the records are for 30 days in instead of 100

0 Likes
dstern
Journeyman
Options
Wearables

It is working only if the records are for 30 days instead of 100

0 Likes
BeefrmNYC
First Poster
Options
Wearables

Thats interesting  because  mines never recorded without sleep mode activation so that could be due to software update changes to protect your privacy. To add to what I said above, when you turn on sleep mode, it will automatically  turn on "do not disturb" feature on on the phone. I just realized that all you have to do is turn off "do not disturb"  if you do not want calls, text messages, and alarm clock to be muted while recording and sleeping.  Best

20220324_013259.jpg

0 Likes