Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Galaxy watch plugin asking for login again and again

(Topic created on: 21-12-2020 08:56 AM)
17448 Views
VikrantSingh
First Poster
Options

Gear plugin keep on asking for the credential on my phone again and again which has cause drain my phone's battery. I have oneplus 6t with Android 10. It really very frustrating and stopping me to use the Galaxy watch.

49 REPLIES 49
liteglow
Apprentice
Options

Is there No fix for this??

Do I need to sell my Samsung clock and buy Huawei?

 

 

This is an incredibly  bad problem that should not be a problem in 2022 😞

 

 

Thank you Samsung for NOT GIVING A SH1TT

Lelick
Journeyman
Options

No.

0 Likes
nicolai1
First Poster
Options

This is very sad. The only cure for me so far is a Samsung phone.

0 Likes
Lelick
Journeyman
Options

I contacted samsung support again. I sent them log files from the watch. waiting for an answer.

0 Likes
liteglow
Apprentice
Options

THIS actualy did the trick for me !!


Please read on to find out how to connect your devices properly:
1. Turn on the Gear. It automatically enters Bluetooth pairing mode.
2. On your mobile device, go to Galaxy Wearable.
3. Tap Connect to Gear.
4. Tap OK when the Bluetooth activation request window appears.
5. Follow the on-screen instructions to complete the connection.


If you do not have Galaxy Wearable Manager (Galaxy Plugin), you will need to install it from Google Play Store.


If you already have the Galaxy Wearable application, please make sure you updated it to the latest version. You can check if you have installed the latest version by opening the Google Play Store, search for the application, click on it, and click on Update (if there is such option).


If updating it to the newest version does not help, please restart your phone and gear. Please know that a simple restart can solve a lot of issues with a modern device.


After the above steps, please perform a reset on the watch by going to Settings > Gear Info > Reset Gear.


After restarting your devices, please follow the steps below:


Go to the Settings of your device > Apps/Applications > Galaxy Wearable, Galaxy Watch Plugin and Samsung Accessory Service (one-by-one) > Force Stop > Storage > Clear Data.
*Note: Since we offer support mainly on Samsung devices, please try guiding yourself on your phone in case the Android version differs a bit.


Then try to pair the two devices again.

0 Likes
Lelick
Journeyman
Options

 

  • do you have a sm-r800 or r810 watch?
  • what region and what firmware version?
  • do you have a data backup?

I have been unable to solve this problem for a year now. Do you think that I did not follow your instructions? I have already used all the methods that are on the Internet. Only one thing helps: roll back the watch firmware to version Tizen 4.0.0.7 or Tizen 4.0.0.4 ... But then the notification about the firmware update haunts. If you reset your watch, you can try to connect it without a phone. Connect via WiFi. Then we can rule out phone software errors. But I warn you, you will not be able to log in to your Samsung account. After entering the username and password, I get a notification on the watch, about the privacy policy ... and that's it. There are no such bugs on firmware with Tizen 4.0.0.4 and 4.0.0.7. So this is a bug of Samsung developers with Tizen 5 version.

 

I will try your method again today.

0 Likes
Members_FtOzhf2
First Poster
Options

Hi everyone, I'm on a honor magic 4 pro. I've tried absolutely everything.

Just had a chat with Samsung support who say they will pass the issue onto the devs. I can only hope that they resolve this issue sooner rather than later. For now I can only suggest as many people as possible contact support and ask them to contact the devs to bring it further to their attention.

liteglow
Apprentice
Options

Did you try to not connect to thw phone, but register clock on WiFi and connect to Samsung account?

 

It's some time since I used my watch, but I got it working. 

0 Likes
RiDEN1
First Poster
Options

Guys, I've found the solution!

For anyone living in a ***hole county like Moldova (in the eyes of Samsung)nu use a VPN!

1) connect your phone to a VPN (I've connected to a German one)

2) turn off Bluetooth so that the watch disconnects

3) turn on Bluetooth and log in to the Samsung account. Accept the new policies

4) You can now disable the VPN until next policy change.

Please like this message if this helped you!

 

BowRiver
First Poster
Options

You're a Genius... It worked perfectly. 

I'm in the UK, but my GALAXY Active came from Germany. 

I VPN'd to Germany and I could complete that login page

 

Wow.. Thank you again

0 Likes