Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Galaxy watch 4 not showing the current speed/pace correctly

(Topic created on: 29-08-2022 05:48 AM)
Shukhrat
First Poster
Options
Wearables

Dear All, 

During running, my Galaxy Watch4 is not showing the current speed and pace correctly. It usually shows higher speed. For example, it miht show that I am running with 8 to 8.5 kmph speed throughout the exercise, when actually I am a lot slower. Interesting is that the Average speed is always correct. So, at the end of the exercise above, when throughout the exercise it shows my current speed 8-8,5km/h, the average speed will be 7km/h only. This totally disrupts the meaning of the running exercise where I have to control the current speed for different laps. 

I had GW3 previously and until the last firmware update, it was showing perfectly correct current speed. I changed it to GW4, in a hope that this is solved in the newer watch, but I see that the problem is still here. I guess that this is a software error, as it is present in both watches. 

Has anyone the same error? Maybe some solutions? 

Thank you for your attention!

Kind regards! 

 

0 Likes
0 REPLIES 0