Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Galaxy buds mic issues

(Topic created on: 26-04-2019 08:27 PM)
21848 Views
Sam993
Apprentice
Options

I've had my buds for about a month . The sound is perfect when I play music, loving the touch pads. But when I call contacts while wearing them they struggle to hear me. I have to shout for them to be able to hear.  They say I sound far away and quite .  Is anyone else having this problem or know of a fix or have I got faulty buds. 

 

Thanks . Sam 

14 REPLIES 14
Baywatch
First Poster
Options

I've just got my pair of buds and unfortunately I experience the same issue with low quality of mic. It is disappointing as they are being presented as a high quality Samsung stuff.

 

Has anyone found any resolution to that problem? Has Samsung taken responsibility for this setback?

A_schaffer
First Poster
Options

What i noticed with my buds+ mic is, when i record sounds it has bad quality, but i noticed after some tests that it isn't using the buds+ mic to record, but it is using the cellphone mic instead, i don't know if there is a way of changing the microphone preference on s20+....

WhDa
First Poster
Options

One Bud = okay mic, Two Buds = bad mic

I cannot find a fix for this, but it seems many people are having this problem.  I've noticed though, that when I put one of the buds back in the case (leaving the other in my ear) that the the person I am talking to says that the sound improves greatly - from they can't hear me or I sound like I'm in a tunnel to sounds great.  I'm guessing that when you have one in, it is using the one bud's mic, but when you have two in, it is either using both mics or the phone's mic.  I think it is both because when I have it connected to my computer (and my computer is right in front of me) the mic problem is still there with two buds in even though my computer mic should pick up my voice great if that is what is happening.

So, do I return the buds and go back go LG (which I've loved for the last 6 years) or is there a solution to this issue?  I've cleaned, reset, turned off ambient...done all of the basic stuff suggested from the other complaints.  Updated the software too.  Let me know.

0 Likes
aBitOfBinary
Apprentice
Options
I was told you can have them repaired as it's a known hardware issue
MelMelRCJH
First Poster
Options

I had to google the same issue happening to me after a month of use and found this thread.  I contacted Samsung about it and they told me they would send me a shipping label to send out the buds pro to a repair center and then I have to wait up to 2 weeks before they will send them back, assuming it's a repairable issue.  I'm beyond frustrated.  These things were incredibly expensive, there's an obvious issue or this thread wouldn't exist and the best I get is they will take them in and repair them.