Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Can't receive or make calls on watch 5

(Topic created on: 31-08-2022 12:38 PM)
footsy
Journeyman
Options
Wearables

Hi. I now have the new Samsung watch 5. All is good apart from I cant make or receive calls without having my phone on me (so when I leave the house I have to take my phone with me.  A bit pointless!)   I have a galaxy S21 plus 5G and I have Ver 12. So can't think this would be a reason for it not to work.  I've contacted the mobile provider (o2) and they've checked everything and say the settings are OK and samsung say the same (but they will replace my watch but don't think that's the issue as its brand new)

The o2 shop have a 5G bolt on that can't come off (they've tried) could this be the issue or have I missed a very important check box somewhere on the watch or phone.? I have updated all software (which there wasn't any). 
I haved checked the esim is on my mobile phone and it is.. It's becoming frustrating 
Does anyone else have this problem?
I have two Google accounts but can't see that this is the issue? Or could it be? I have moved my sim card (physical card into sim 1 as it was in sim2 and thought this could be causing an issue but no) 
 Any suggestions would be greatly appreciated TIA
0 Likes
14 REPLIES 14
Easty
Hotshot
Options
Wearables
Have you got mobile data turned to auto on watch ? Swipe down , the 2 arrows ( 1 up , 1 down ) should be blue
Samsung Galaxy Note 10 Plus 5g
Samsung Tab S6 Lte 256gb
Samsung Galaxy Watch
Easty
Hotshot
Options
Wearables
Hold it and scroll down, touch mobile plans , o2 plan should show
Samsung Galaxy Note 10 Plus 5g
Samsung Tab S6 Lte 256gb
Samsung Galaxy Watch
Neo001
Big Cheese
Options
Wearables

Hi,

Have you toggled on Remote connection in Watch Setting --> Advanced features --> Remote connection --> Calling?

Also, on your Galaxy phone, in the Settings--> Advance features --> Call & text on other devices - toggle it on.

Needless to say, Watch should be connected to WiFi (connection can take a few seconds to a minute to be established).

I have observed that it can take a couple of retries before the call is successfully established. Your phone and watch need not be on the same WiFi.

Hope this helps.

footsy
Journeyman
Options
Wearables
Hi. Yes thats on. Happy to receive any comment because maybe I've missed something. Keep them coming :smiling-face: thanks
0 Likes
footsy
Journeyman
Options
Wearables
Hi. Thanks. This is all correct. Still nothing. It says emergency calls only. ..??
Should I (if my phone is at home) leave my phone switched on and on WiFi and bluetooth? Which means I would have to keep it charged whilst I am.out? This is what the shop told me but still doesn't work anyhow, but thought I'd ask for when I do get it working. Keep the suggestions coming... I may have missed something
0 Likes
footsy
Journeyman
Options
Wearables
Yes. This says connected to o2. Keep suggestions coming. Thanks
0 Likes
papashaun
Helping Hand
Options
Wearables
I believe with O2 although your phone isnt with you, you still need your phone on and connected to wifi
Could also try turning on calls and texts on other devices on your phone - Settings - Advanced Features - Calls & texts on other devices
( might also be worth doing search on the forum - quite a few people have had problems getting their watch to work on O2 and there are several previous posts on the forum which may help )
footsy
Journeyman
Options
Wearables
Thanks for confirming this. I'll do a search
0 Likes
IndiW
Voyager
Options
Wearables
This is something to do with O2 not the watch, only EE provide truly independent service or without the phone lte service in the UK 🇬🇧, all others use the phone as a piggy back service
0 Likes