Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

Picture clarity setting grayed out on external HDMI source

(Topic created on: 24-10-2023 05:12 PM)
925 Views
s4msb
Apprentice
Options

Just got the S93C and wanted to use the frame interpolation on a Blu-ray that is played on my PC. So I connected it with an HDMI cable but the "Picture Clarity" menu is grayed when I select my pc as source. How do I fix this?

Can't believe that I couldn't find a thread about this...

0 Likes

1 Solution


Accepted Solutions
Solution
Phoenixia
Apprentice
Options
Because certain options in there aren't generally suitable for general use and can issues or annoyances, for example the input lag that Picture Clarity brings. So you basically go to your home screen, by pressing the House on your remote control. Press Left and you'll see Menu with 3 lines, press down and it'll select it and you'll see Settimgs, Connected Devices and Multiview. Click Connected Devices. Press right twice and you'll see the sources on the bottom, with SmartThings being thr first icon followed by TV etc.on the left down to Connected devices or Smartthings. Select your pc icon, click edit, and change the icon/type to something like BluRay player from the list dropdown. Now your TV will treat it as a media device and change the available settings presented that you can adjust. You should now be able to use Picture Clarity Settings. Don't turn Game Mode on during this, or it will revert to pc again / change the device icon in the menu I showed you earlier into a Games Console. What you CAN do is go to the settings, Connection > External Device Manager > Input Signal Plus and enable it for basically all the HDMI ports. If you don't usually use this with your PC or the S93 somehow didn't, once you change your "Bluray" back into PC, go to the all Settings menu, down to Connection and click it, click External Device Manager, Input Signal Plus and make sure it's on for your pc. You can also go back, and underneath you'll see Game Mode. Turn it on when you're usually using your PC or basically anything other than Blu Ray stuff. Turn it on and you'll also see Surround Sound turn on (blue checkbox). You can adjust a few more things in this menu to make the most of it as a monitor, experiment around and you'll find you'll end up with the perfect settings and no input lag.
Just wanted to throw this out there for you all, enjoy!

View solution in context

3 REPLIES 3
Solution
Phoenixia
Apprentice
Options
Because certain options in there aren't generally suitable for general use and can issues or annoyances, for example the input lag that Picture Clarity brings. So you basically go to your home screen, by pressing the House on your remote control. Press Left and you'll see Menu with 3 lines, press down and it'll select it and you'll see Settimgs, Connected Devices and Multiview. Click Connected Devices. Press right twice and you'll see the sources on the bottom, with SmartThings being thr first icon followed by TV etc.on the left down to Connected devices or Smartthings. Select your pc icon, click edit, and change the icon/type to something like BluRay player from the list dropdown. Now your TV will treat it as a media device and change the available settings presented that you can adjust. You should now be able to use Picture Clarity Settings. Don't turn Game Mode on during this, or it will revert to pc again / change the device icon in the menu I showed you earlier into a Games Console. What you CAN do is go to the settings, Connection > External Device Manager > Input Signal Plus and enable it for basically all the HDMI ports. If you don't usually use this with your PC or the S93 somehow didn't, once you change your "Bluray" back into PC, go to the all Settings menu, down to Connection and click it, click External Device Manager, Input Signal Plus and make sure it's on for your pc. You can also go back, and underneath you'll see Game Mode. Turn it on when you're usually using your PC or basically anything other than Blu Ray stuff. Turn it on and you'll also see Surround Sound turn on (blue checkbox). You can adjust a few more things in this menu to make the most of it as a monitor, experiment around and you'll find you'll end up with the perfect settings and no input lag.
Just wanted to throw this out there for you all, enjoy!
s4msb
Apprentice
Options

Wow thanks! This is actually a pretty clever solution from Samsung to not annoy gamers with interpolation.

Phoenixia
Apprentice
Options
Indeed it is! I suspect it's because there's always that slight off chance of the automatic detection being wrong so they put options in there as workarounds even though they're hidden or obscure to find except by chance which is how I discovered it, I too had a similar issue and was trying to find a workaround which I'm glad was able to help you too :smiling-face:
0 Likes