Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

DD+ and Atmos problems on Netflix and Prime video

(Topic created on: 09-10-2022 01:45 PM)
Gilad Avital
Apprentice
Options
TV

Hello.

On my QN90A no dolby digital or dolby digital plus on Netflix or Prime video.

When playing movies that have 5.1 my Yamaha receiver shows PCM(About a week ago it showed DD+)

When playing Atmos movie the receiver shows Atmos/PCM(about a week ago it showed Atoms/DD+)

Any suggestions?

Thanks.

0 Likes
8 REPLIES 8
Obsydian
Hotshot
Options
TV
If there is an available option select pass through
Regards, Obsydian

DAILY DEVICES
ZFold4 [Mobile], Pro5 [Watch], S8 Ultra [Tablet], Book2 Pro i5 5G [Laptop], Buds Pro2 [Buds] M70A 32/43" [Monitor], Smart Tags+, iPad Mini 5 and iPad Pro 12.9 GEN2 [Tablets], Dell Inspiron G5 Laptop

HOUSEHOLD DEVICES
ZFlip3 and ZFlip4 [Mobile], Watch5 40mm and 46mm [Watch], S7+ and S6 Lite [Tablet], QN95A [TV], Q900A [Soundbar], MC28M6075 and MC32K7055 [Microwave], Jet 75 Complete (Vaccum), Samsung Level [Speaker], Buds Pro [Buds], iPhone 12, iPad Air 2, Air tags
0 Likes
Gilad Avital
Apprentice
Options
TV

Unfortunately, there is no option for pass through only PCM or AUTO...😪

0 Likes
niniki
First Poster
Options
TV

As you are finding out, Atmos is a BIG problem in Samsung TVs and has been for years!

Currently, when I go in to Netflix, everything is given as 5.1. When you check the TV setting DD+ is disabled.

However, if I select something that I know should be in atmos, and start watching, suddenly the amp gets told by the TV that it can use DD+ after all.

You might think that's solved it. Nope.

If I hit back, Netflix now says it's Atmos, but playback remains in DD÷.

The only way I have gotten it to actually play Atmos is to start playing an episode,  wait for the amp to show DD+, then fast forward to the end of the episode. Then the next episode shows up at Atmos on Netflix AND my lousy Samsung TV finally tells the amp its Atmos!

As someone who spent their life in IT programming HARDWARE-PC communications it absolutely reeks of appallingly bad hardware handshaking. I'd like to blame whoever wrote the handshaking code in Samsung, but Apple and Disney Atmos is seamless. So either the Samsung code is awful and Apple/Disney have genius developers or the Netflix coders are *****. Can't comment on Prime as there's so little Atmos content I've no idea if there's a problem :smiling-face:

In general the Samsung software is an absolute joke -  more bugs than an ant hill. Also had the "too many reservations"  bug tonight, where you've to run auto tune to be able to record again. I'm sorry I didn't spend my £3k on a different brand.

So if you can be bothered with all the faff without putting your boot through the screen in frustration, try the fast forward through an episode trick

0 Likes
SO_SESK
Explorer
Options
TV

Hello.

First, check, that Your software version is T-NKM2DEUC-2101.0 or newer.

Then make sure in HOME -> Settings -> Sound -> Expert Settings the below options are set as following:

HDMI-eARC Mode: Auto

Digital Output Audio Format: Auto

Dolby Atmos: Enabled

 

Second, in Netflix play some movie that has the Atmos sound. While playing the movie, press the OK button on Your remote and from the bottom menu select "Other..." -> "English[Original] (Atmos)" -> OK

 

Check the audio track format on Your receiver.

Gilad Avital
Apprentice
Options
TV

Hi

All settings on the tv are as you wrote.

All settings on the receiver are correct.

Still all Dolby 5.1 movies/shows are recognize on the receiver as PCM(instead of  DD or DD+).

All Atmos movies/shows are recognize on the receiver as ATMOS/PCM(instead of ATMOS/DD+)

Thanks.

0 Likes
SO_SESK
Explorer
Options
TV

I see.

 

If I  got the situation right then what You are experiencing is that You are getting the "Multi-channel PCM" sound data out of the TV when playing DD 5.1 movies (not stereo PCM data, right? Check this on the receiver).  Multi-channel PCM support is related to the HDMI-eARC Mode option specification.

The TV choses to use multi-channel PCM format often automatically (since the option Digital Output Audio Format is set to Auto) and then keeps 5.1 audio channels and in that case it is not considered as "down-converting" of audio. On the contrary it uses a higher bandwidth of the HDMI eARC connection.

If I am right and there is no other issue with sound then once You disable HDMI-eARC Mode You should start getting the DD/DD+ sound again. But this audio format would not provide any improvements in terms of sound quality.

Please check it.

Gilad Avital
Apprentice
Options
TV

Hello.

You are right!

Disabling HDMI-eARC does bring DD/DD+ back.

According to what you wrote about sound quality,multy channel PCM is better?

Thank for your reply.

0 Likes
SO_SESK
Explorer
Options
TV

Let me put it this way.

If TV sends DD/DD+ audio to Your receiver then the receiver displays the sound it receives which is DD/DD+ but then the same receiver has to transfer the received audio to each channel as PCM (or LPCM actually) which is an additional job it must do. In ideal cases it is no problem. Sometimes however some minor audio / video synchronization issues MAY show up, it really depends on each device type.

If TV is able to create a lossless multi-channel PCM audio data (which Your TV can) then the job for receivers is different, PCM data is huge but my opinion is that it is also more compatible for processing by receivers, You will not notice any difference in the sound quality in case of a proper functionality of all Your devices. You may however (and probably will) notice a difference in the sound level because the audio volume data may get altered on the audio track. You can find more information here: https://thehometheaterdiy.com/what-is-dolby-mat/

 

My advice is to use the option which gives You better results in terms of what You hear from Your setup.