Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

NHS Covid App - Tab S3 and Tab s6 with phone sims - your device is not compatible

(Topic created on: 03-10-2020 07:48 AM)
506 Views
mandy66
First Poster
Options

Hi, the Tab s3 is on android 9 and i have used the Yan Tools Bluetooth Low Energy Checker = Pass

NHS says marshmallow or above is required

 

I get nonsense answers from nhs covid app support - including those telling me that the nhs app and the nhs app are different and I have used the wrong site (when I havent)

 

Any suggestions - or give up?

2 REPLIES 2
ryukariotu
Voyager
Options
i have a tab a on android 9, same problem for me. its probably a problem from the developers. however, they did say it was available on all android phones android 6 or above so the problem may be that it only works on phones.
0 Likes
leaves123
First Poster
Options
I'm having a problem setting up the covid 19 app on my phone as well. The advise I got from the support team was a link to the nhs site so I'm going to post on this site. sorry this won't help but thought I would say I've got a problem on a phone.
0 Likes