Support

Open search

Galaxy Tab A 2019 Charging issue

Highlighted
New Member
My tab A was brought in February. It has always been charged using the plug and lead provided. It has never received any damage and the tablet has had very little movement whilst on charge however I keep getting a very slow charge message and process. It spent 4 hours on charge to increase by 4 % at its worst. It now averages 10 to 20% over numerous hours. Message says to use the lead provided or that the lead is damaged. Its 6 months old! I was planning my phone upgrade to be samsung but now I am not so sure. Anyone have any ideas or fixes? Thanks in advance.
4 REPLIES 4
Highlighted
New Member
try using a new lead.or you can try taking it to a Samsung store and book to have it checked by Samsung.
Highlighted
Thanks gor replying but sadly I do not have any other samsung leads and as it is only 6 months old I can't bring myself to buy one. I genuinely do not know of any Samsung stores near me and, if honest, do not believe I have ever seen one. Thanks agsin
Highlighted
New Member
I have had that same problem on my tab A i just replaced the lead with a cheap one from a local shop and my tablet has been charging fine to 100% in about 1 hour I know we shouldn't have to do this my tab A is only 6 months old also hope this helps
Highlighted
Thanks, knowing a cheaper generic one will work mean I might actually be able to buy one without throwing up. I will give Samsung the oppertunity to rectify it first. Do they monitor their forums?
Top Liked Authors