What are you looking for?

Showing results for 
Search instead for 
Did you mean: 

Original topic:

Sim card not recognised after Android 9 (pie) update

(Topic created on: 15-05-2019 10:37 PM)
First Poster

Hi everyone, I have a problem which appears to be a bit similar to this one in the US forums, but worse:


I bought an unlocked Galaxy S8+ SM-G955FD from Giffgaff this week and used my old nano SIM on it - worked absolutely fine. My phone fits a single SIM only (not dual).


I kept getting prompted to update the android software on the phone though so went through with it - twice. I don't recall what version of android I was on before but I am now on version 9 - Pie. The first installation worked ok (presumbaly upgraded to Oreo), but after the latest one, my SIM isn't recognised, none of the mobile network options are available in Settings and it keeps saying "insert SIM". There is nothing wrong with the SIM as it still works on my old phone.


Also the IMEI numbers have disappeared from About Phone. Pressing *#06# in the keypad, which should also reveal them, keeps making the phone freeze.


After googling - I have literally tried everything under the sun- rebooted, re-inserted, cleaned the SIM, reset connections, rebooted and wiped cache partition, I even did a factory reset - but that did nothing - the exact same problem persists. (The factory reset retains the same android version 9).


One thing I noticed was when I boot in recovery mode (to wipe cahe partition) I see the following message at the bottom of the screen:

#fail to open recovery_cause (No such file or directory) #
#report recovery cause is [unknown] #
Support single-sku
File-Based OTA
Supported API: 3
e: unknown volume for path [/ odm]
e: unknown volume for path [/ vendor]


# MANUAL MODE v1.0.0#

remove failed dir  ‘/system/carrier/ATT/priv-app/AttIqi_ATT’ (No such file or directory)

E: [libfs_mgr] is_dt_compatible (): firmware info was not valid : '/ proc / device-tree / firmware / android / compatible': No such file or directory


Does this mean anything relevant to the SIM and does anyone know how to fix this?





First Poster

Have you been able to find any solution to this? I am having the exact same issue

First Poster

Nope. The only thing I hadn't tried was rooting the phone which I didn't want to attempt.


Had to send the handset back to giffgaff for a replacement. Still waiting for it.

First Poster

Please i have the same issue + device doesnt show ime + no arabic language in input + storage changed from 64 to 16 GB