Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

SIM 2 can not receive SMS when on phone using SIM 1

(Topic created on: 16-02-2022 10:02 AM)
85417 Views
Geogre
Journeyman
Options

S21 Plus

Why can I not receive an SMS on my sim2 when I am on the phone using sim1?

It never works. I have a phone bundle on sim1 but use sim2 for personal banking etc..

So when I am on the phone using sim1, they are trying to send me an sms on sim2 as that is the number that is registered to them. Makes sense?

What setting is not right or is this not possible? On my Huawei and Motorola, it was a very fluid experience.

Help.

15 REPLIES 15
Bearmanx
Student
Options

Try going to Settings/connections/SIM card manager. Check if both SIM cards are enabled, then further down to which services you wish to receive from each SIM card. 

Hope it helps 

0 Likes
Geogre
Journeyman
Options

Hello. Thanks for the swift response. I tried that. I have been playing around in that menu and nothing. It is only allowing me to do call forwarding etc. Activate Dual SIM always. It is not affecting the SMSs though.  


I think this is a fail from Samsung. Not a big fan of the phone, so will just live with these quirks. There are many. 

Thank you though!

 

0 Likes
Alfsdad
Voyager
Options
I have two sim cards in my S21 and have no problems getting SMS and voice on either sim at anytime.
0 Likes
RXM
Troubleshooter
Options
That's because you used to have a Dual SIM Full Active (DSFA) phone where both SIMs can receive incoming calls and texts and you now have a Dual SIM Dual Standby (DSDS) phone which puts the other SIM into standby mode when the other is in use.

The amount of DSFA phones out there is much smaller than DSDS which is the most common.

It's not a feature I'd ever need. In the example provided to help me understand, why would you need the person your talking to to send you a text? I'm sure there lots of utility in that type of Dual SIM but for my use case I can't think of any.
0 Likes
andy765
Student
Options

Solved (at least for Motorola)

I had the same problem when overseas :
- Bought local sim, placed in primary slot (SIM 1)
- Moved sim from back home to secondary slot (SIM 2)
- Activated data on local sim to get internet connection.
- SIM 2 SHOULD have been available still for SMS and phone calls.
BUT it wasn't.

So two-factor authentication was impossible because SMS
messages were not arriving on SIM 1.

My phone is Motorola, not Samsung.

But my solution was as follows :
- On both sims, under Settings/Network and Internet/tap on one SIM 1 / SIM 2 respectively.
For both SIMs, there are options for 'Call preference' and 'Messages preference'.
[ The default values for both had been SIM 2 (so causing SMS messages to be blocked). ]
- Change 'Call preference' and 'Messages preference' to 'Ask every time'.

Works perfectly.

Hope this helps

sekito
Journeyman
Options

I have the same setup and issue.

sim2 for personal banking

But sim2 NEVER receives sims unless I'm doing a call on sim2 and then hang up just as they send an sms.

So if someone calls me from the bank, half the time it says the phone isn't connected.

If I use net bank and it sens a 2fa sms, it never arrives. I have to go in settings, disable sim1, then get the sms sent.

I can't believe Samsung Galaxy S21 phones cannot use dual sim.

sekito
Journeyman
Options

Can you try pressing details on the esim sms. It arrives, but I see send time 5.10, receive time 5.35. Usually 5min or more wait. While other sim is 1min.

0 Likes
S22 ultra5
First Poster
Options

Am too facing same problem.. Sim 2 SMS not working. Kindly fix this as it's required for OTP verification 

0 Likes
AlexandraTheGreat
First Poster
Options

Same problem, absolutely furious with it. Been all over the net for solutions, done all the permutations of settings changes and not a sausage.  Useless responses from people who can't think why one would need this option, great help there, thanks - or saying it works on a different phone - ditto. I use one SIM for personal and one for work, and it ain't working. 

0 Likes