What are you looking for?

Showing results for 
Search instead for 
Did you mean: 

S10+ rSAP not working

(Topic created on: 18-11-2021 10:02 PM)
First Poster

Hi everyone, I've been trying to get my euro spec Exynos S10 Plus (Android 11, latest firmware as of November 2021) to work with the Bluetooth (SAP) telephone module V4 in my 2005 Mercedes S-Class for a couple of days now, but I seem to have come across an unexpected technical issue. First things first, It seemingly connects to the car, so I don't think that's the problem here. According to the infotainment system of the car and smartphone alike, the rSAP connection is successfully established automatically every time I get in the car, with both SIM and contact access permissions being granted on the phone. Data from the SIM card is read successfully, as well as a list of the recent outgoing calls is transferred to the car's COMAND system. The weird thing is that despite this apparent success, I cannot make or receive any calls over rSAP. Also, neither the phone book, nor the SMS directory are accessible via the car's infotainment. I tried a different phone, I have an ancient SIemens S65 that supports SAP , which paired to the car's bluetooth system right away, allowing making and receiving calls, phone book and SMS access, no problems at all. I tried resetting the Bluetooth module to factory settings. That didn't work. I also believe there is no newer firmware available for it. So I'm at a loss what could be wrong. Have any of you guys run into a similar issue and do you happen to have any suggestions as to what could be wrong/what I am doing wrong and what I could attempt to make this work? Thank you very much in advance.