Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Problem with VPN over Hotspot

(Topic created on: 10-08-2022 06:56 PM)
7835 Views
John Patounas
Journeyman
Options

I have got 2 days ago my new Galaxy S21 Ultra and installed all the updates.

I have a problem and the VPN on my laptop wont connect when using mobile hostspot.

It is not a provider problem because i replaced the sim card to another phone (Huawei) and works without problem.

Please advise how can i solve this as i need it to work. I am working remotely and the VPN over hostpot is a must for me.

 

Thanks in advance.

19 REPLIES 19
ick666
First Poster
Options

I had the same problem with a Samsung Note 20 Ultra (and previous Samsung phones).

I found turning off the WiFi on the phone when using the Hotspot to connect to a company VPN works.  

This works for me, and can still connect on 4G for better transmission speeds.

hope this helps others as well.

0 Likes
Restaurateur
First Poster
Options

I don't think this is a SIM issue. It sounds more like an Android issue. As great as Samsung phones are, their security is not as good as iPhones. So when connecting to a laptop, the VPN will only protect the data from your phone and laptop. However, it will not protect the hotspot data, which is why it might not connect. The phone might detect that the connection is not secure. You can try to fix it and buy a proxy. They are specifically done to assure security while using connections or transfers. Perhaps it will work. If not, try to download a VPN security app.

0 Likes
frank9991
First Poster
Options

This is all BS, i was just fine with my old gx10 now this 5g ***** is not letting me make money i need laptop to connect , is not there something i the settings to permit my laptop vpn protocol to be allowed, this is very crappy, we are not all mindless teenagers twirling in their 1Gran heavy oversize next , planned obsolescence device. 

0 Likes
Joe-Mama
First Poster
Options

Any other suggestions to correct this?

The 3G solution did work.  Unfortunately here in the United States all companies are cutting off 3G service to focus on LTE/5G.  I'd be rather shocked if there wasn't a 3rd party app that could solve these hiccups with hotspots.

0 Likes
jonelli
First Poster
Options

This is not working.  I am supporting a business owner with a new S21 who can no longer use his phone as a mobile hotspot to connect his business laptop to his own business.  
I have 100% determined that it is THIS phone on T-Mobile blocking the connection.  There is no 3G service to switch to anymore, so that workaround is not useful.    The other suggestions/resolutions are not related to the actual problem, those are generic.  I can use any other device on the same T-Mobile network to connect.  I have looked at the Sonicall itself to monitor packets, and none are arriving on the GVPN ports 500/4500 when tethering through this phone.  
The really stupid thing is that you can download the GVPN app to the phone and connect just fine.  But all tethered traffic goes around the phone's VPN, so it's then blocked.  Stupid.  
Haven't found a solution yet.  Called SonicWall and Tried T-Mobil, still no solutions... it's the phone.

0 Likes
jonelli
First Poster
Options

Another interesting piece of information... We were able to connect the S21 via WiFi to a different phone's hotspot and then tether the laptop to the S21, and it was able to connect  the GPVN client successfully.  
So, again, it's an S21/5GLTE problem. 

0 Likes
Members_ymBSCs2
First Poster
Options

I have the same issue on a S22 Ultra : VPN is not working i have to switch to 3G.

I didn't have the issue on my note 10.... 

Such a disappointment....

0 Likes
Rectangle
First Poster
Options

I like how this topic is listed as solved...

It is NOT SOLVED.

I have a Samsung A53 work phone with a laptop with a remote managed fortinet VPN. I need to be able to connect to that VPN via my phone's hotspot when I am out in the field, in order to access my files.

It simply doesn't work. Changing to 3G doesn't work as the connection times out due to slow speed.

This is an issue that need to be resolved Samsung!

0 Likes
Baptistech1
First Poster
Options

Hello guys, i think i found a solution to the problem.

the problem seems to be the use of ipv6 in the apn setting.

In the parameter : go to connection/mobile network/Access point names and add an acces point. Put the same information as the one used by default except for APN protocol that must be set at ipv4.

 

It worked for me so hope that it works for you too.

Ui-Two
First Poster
Options

Thank you so much for this Baptistech1.  I too had a problem with using my S23 Ulta as hotspot and using a laptop to connect via VPN. I could not get past the secure connection via RDP and network drive was not connecting. After what you suggested and adding a new Access Point. It works!!! Thank you thank you thank you!!!!

0 Likes