Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

My battery drain on S21 ultra seems to drain too fast

(Topic created on: 11-06-2021 05:11 AM)
2101 Views
JohnB5
First Poster
Options

I have the S21 ultra snapdragon version, with all default settings however I notice my battery will drain 5-8% within less than an hour with basic browsing, i have performed a factory reset and this still occurs. If i play games or anything  a little intensive it will drain even faster.

198463387_2926005730975827_4415407198937249311_n.jpg

 

7 REPLIES 7
AshtabS9Ultra
Mastermind
Options
I always find with samsung phones the first 10% goes like hell then it settles down. That still seems excessive for the ultra though. I do know that Facebook uses a lot of battery as it's always loading videos while you are scrolling.
adamlee
Big Cheese
Options
May update causes battery drain.. also this wakelock which has been around for months while device ID moving it drains in standby.

https://forum.xda-developers.com/t/cameraservice_worker-partial-wakelock.4234161/
0 Likes
Maria_vm
Troubleshooter
Options
Im lucky its not that way with my A51 5g, the battery just lasts ages no matter what stage it is at. That is excessive battery drain tho especially for Snapdragon. Possibly a bad app?
0 Likes
Pugs1957
Samsung Members Star ★
Options

Your battery stats would provide better information over a longer period. The graph only shows 54 minutes of usage, however, one thing stands out and that is the fact Facebook has used 1.5% of your charge in 8 minutes ehich means that app alone will use all of your battery in 9 hours.. That is not good but it is down to the app, not your phone.

0 Likes
AndrewL
Moderator
Moderator
Options

@JohnB5: I can't see anything too alarming here, although as mentioned by @Pugs1957 apps like Facebook can be more power intensive than others. Keep monitoring your battery, and in the meantime please check out the following energy saving tips to help improve your overall battery life. 

- Shut down all background apps when not in use via the Recent Apps button
- Settings > Connections > More Connection Settings > Nearby Device Scanning > Off
- Turn off Wi-Fi, Mobile Data and Bluetooth when not in use
- Head to Settings > Battery and Device Care > Battery > Power Saving Mode > On, and check the additional options below
- Go back and select More Battery Settings > Adaptive Battery > On > Enhanced Processing > Off.

GoanGeek
Samsung Members Star ★
Options
I have noticed it with my Ultra as well. I thought it was a common occurance as it doesn't seem to affect the overall battery performance.
0 Likes
adamlee
Big Cheese
Options
Really sick and tired of seeing the same copy and paste crappy solutions. We've done all this. I've tried FHD 60hz. Power save mode. 2g only, deep sleeping all my apps. Turning location Bluetooth NFC off. Sync off. The battery is still *****.
0 Likes