Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Google Voice Typing is not working after recent Android update.

(Topic created on: 24-01-2022 02:02 AM)
24722 Views
lemonjoyce
Journeyman
Options

Google Voice Typing is not working after recent Android update.

I use English language on my S20+. Before the update i can use Cantonese on my Google Voice Typing, even my keyboard setting is only set as 'English''.
After the update, the Google Voice Typing can only understand English, I tried to go into the setting, add new language, I cannot see Cantonese as an option anymore.

And if I click ''Default Language'' under Language, Cantonese is shown as an option but there have no 'save' or 'ok' button after I have checked the box. (Please see attached)

271961720_229837542666223_5841620062222898736_n.jpg 271946453_1034863230576799_8993706518926130347_n.jpg No Save or OK buttonNo Save or OK button

I also see that in Setting, Keyboard list and default, have an option ''Google Voice Typing [Legacy], which was not there before the update. (Please see attached).

Please help if you know any solution, I can speak Cantonese, but I cannot type it, so this dictication method is very useful and necessary for me. Thank you.

  271916150_1079275152897688_835401616139226955_n.jpg

 

 

1 Solution


Accepted Solutions
Solution
Noosiekins
Journeyman
Options

I managed to get the old version back! I went into Google play, looked up "Speech Services by Google" Go in there and hit "uninstall". Then hit the ... and from there, un check "enable auto-update".

 

Restart your phone and the old version of voice typing will come back and the "Legacy" is no longer on the phone :smiling-face:

View solution in context

53 REPLIES 53
TessM
Mastermind
Options

Hi @lemonjoyce ,

As you've mentioned that you've tried pretty much everything, could you let me know what you've tried so I can provide you with any steps you may have missed?

I would recommend sending an error report in the Samsung Members app, so our engineers can get a better understanding of this. To do this, head into the Samsung Members app> Get help> Error reports> Select a category and fill the box with a brief description of what is happening after reproducing the issue. Remember to add some screenshots of the issue or a video displaying this.

Once this is sent off, our colleagues will get in touch with more information once an engineer reviews your query.

vkinhk
Journeyman
Options

I have exactly the same issue. Very frustrating as it actually unusable.l

lemonjoyce
Journeyman
Options

Hi Tess, as I have mentioned in my post, I have tried whatever I can and understand already.

I have contacted Samsung call support, even let them remote my phone but still no luck. The support said will look into it with technician/ energineer and get back IF any solution.

vkinhk
Journeyman
Options

A short term solution is to use Google's GBoard keyboard app - the voice correctly works.

lemonjoyce
Journeyman
Options

Ya that's exactly what I am using now after wasted a whole weekend and tons of times to find a solution. 

Members_jgMNRdO
First Poster
Options

+1 upvote. same problem here on S21

R0M3KR3NV4Y
Journeyman
Options

I have the exact same problem. Very, very frustrating. No way to select or add another language besides English. Please fix this. Using Samsung S20.

Pailin
Student
Options

I have same problem like you  After updated I can't use Thai voice typing option too. cause my phone( Note10 light) default languge is Korean but  when I use voice option I usually use Thai  but it doesn't work after update!!!

 

William W
Student
Options

I have the same issue on my Galaxy S20, after the oneui4 update.

Found a workaround that worked -- in settings go to "Keyboard list and default" , then disable "Google Voice Typing" (i.e. the one that shows all languages but won't let you save), and make sure "Google voice Typing [Legacy]" is enabled.

 

That worked for me.