Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Printing to a network using Android/Samsung phone

(Topic created on: 26-03-2024 05:03 PM)
900 Views
Members_6YK691p
First Poster
Options

Printing to a non-WiFi network printer from Android 13 Samsung Galaxy A32 5G phone.

I posted a few months ago about this but got no replies so am trying again.

I have a Canon Pixma G2510 usb printer, connected by usb cable to a repurposed Fritz!box wifi router, functioning as a wireless repeater in my Wifi mesh.

The printer works as a network printer and my desktop PC and laptops, both using the Linux Mint xfce64 OS, can print to it, using the WiFi network.
They give the url of the printer as 192.168.178.31 (the address of the wifi repeater) and the port as 9100.
In printer properties, in Linux, this is given as "socket://192.168.178.31:9100"
the printer properties indicate that it is shared.

I have so far been unable to get my Galaxy A32 5G phone using Android 13, to locate the printer and print to it.
When I try and set up the printer, using the recommended methods for a network printer, and giving the url used by my Linux devices, it cannot find a printer at that address.

I have also tried downloading both the Canon Print Service app, the Canon Print App, and the Samsung Print Service app and also tried the Default Print Service from the Android OS. Entering the network details into all of these produces failure to find the printer, every time.

The Canon Print Service app has no means of entering port information and can't find my printer with just the IP address of the WiFi repeater it is connected to by usb. The error message is "could not find a supported printer".

The Canon Print App can't find the printer (I think it only looks for WiFi printers, so that isn't much help - my printer is not listed as one of the supported printers).
The Samsung Print Service app allows me to enter the url including the port number, but still can't find the printer - error message is "unable to communicate with this printer".
The Android "Default Print Service" accepts the full IP address then searches ad infinitum, finding nothing. Leaving out the port number makes no difference.

Nowhere does the Android software suggest that it is not possible to print using a network printer. Yet, although Linux Mint is able to print via the WiFi network, on this printer, even waking it up remotely when it is in sleep mode, nothing I do on my Android phone is even able to find the printer let alone use it.

I have consulted several help/support forums online, including this community, without finding an answer.

Is it possible for my Android phone to access a non-WiFi network connected printer, in the way that my Linux desktop PC and Linux Dell laptop can?

Samsung support
Canon Printer Support

0 Likes
0 REPLIES 0