Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

S24 Ultra Wifi and carier wifi issue

(Topic created on: 07-06-2024 10:52 AM)
332 Views
Sweeper71
Student
Options

I bought a brand new S24Ultra yesterday.  When I connect to my wifi6 router there is no internet, but the phone state connected to internet. My wife A25 is connected and test 300Mb/s. I restart 2 times my phone, now it have internet, but the ping is 465, my wife's A25 state 7 ping. My speed goes slowly up to 30mb on the 5g, but I cannot use the internet because it is so slow. Now, I have done everything I have read on the internet, reset wireless and and and. I have 7 days to take this product back. and... We have a big house with 4 different internet units. I have the problem on ALL of them. even if I switch of my wifi and use the Vodacom carrier.. same problem. A25.. perfect on all of them.

0 Likes
3 REPLIES 3
BandOfBrothers
Samsung Members Star ★★
Options

The router sounds fine as your wife's phone is using it fine. 

Perform a forum search to see if theres any other similar advice which may help. 

It maybe an idea to have the phone swapped out within your cooling off period @Sweeper71 

Yoshouldn't have to be troubleshooting at this early stage. 


Daily Driver > Samsung Galaxy s²⁴ Ultra 512Gb ~ Titanium Black.

The advice I offer is my own and does not represent Samsung’s position.
I'm here to help. " This is the way. "

Glenntech
Samsung Members Star ★★
Options
I have WiFi 6 at home and work. My S24 Ultra is very good with the WiFi.
So unless there's something wrong with configuration to your WiFi. It should be much faster.

Have you tested it anywhere else to see if its better on another WiFi network?
Also if you have a case on the phone, try removing it and see if its better. Some cases can interfere with network signals.
I've had this before.

Maybe something you need to go back to the retailer and get a replacement unit
0 Likes
Members_JXLsjk5
First Poster
Options

I had same issue another post mentioned to go in router internet settings and turn off ipv6 use ipv4 instead hope it helps

I am with EE same issues called them to change apn type to ipv4 but they rejected said it split between ipv4 and ipv6 sad 

0 Likes