Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

Sleep mode keeps activating alarm no matter what

(Topic created on: 13-02-2023 02:38 PM)
22943 Views
VinMar
Explorer
Options

Sleep mode keeps activating the alarm no matter what I do. I have gone into the settings and dug down to turn it off and saved it but it reactivates next time. I deleted the current sleep mode then rebooted the phone and recreated it turning off the alarm but it still insists on turning it back on. I've stopped the app cleared the cache pretty much everything I could think of and it persists.

I've finally deleted sleep mode completely and just use the do not disturb under notifications and it's no problem. If you have other options you want to change during do not disturb most can be written into a routine that runs at a specified time period you can set parallel to sleep mode. Sure it's a pain but less painful than the bug that keeps arming the alarm.

Samsung you need to fix this.

Go to solution
73 REPLIES 73
mangojelly
Journeyman
Options

Check my post, because I also preferred not to set a schedule within DND.
I turned off the sleep routine & created a custom routine with the same settings (turning on DND, eye comfort, etc.). I then made sure to deselect sync sleep routine from my GW5 Pro.

0 Likes
VinMar
Explorer
Options

Agreed - Samsung does need to fix this! The work around should not be a final solution. Anyone not familiar with writing routines is kind of out of luck unless someone can show them. 

I believe the modes were put there to help the helpless by making it easy for them but they are also redundant if you are an expert user as all they do is manipulate settings already available if you know where to find them.

VinMar
Explorer
Options

The watch is effected by the problem with sleep mode on the phone if is set to sync so yes, but not a problem with the watch software a problem with the phones sleep mode setting and the alarm.

AshFrazer
Journeyman
Options
I am testing a possible solution. In the sleep mode screen set your times as normal but BEFORE you hit the disable the alarm go into the switches below and disable sound vibrate and sleep. Then turn the alarm switch off too. I think the bug Is that the master switch should turn off the switches below it but if doesn't. It only hides them. With the sub switches on the clock gets confused which is why it comes back on. I have had one successful 24h period so far and the alarm has not re-enabled itself.
Solution
Hetrab
First Poster
Options

I have a solution that turns off the alarm permanently and maintains the features of Sleep... From settings go into Modes and Routines, select the sleep mode. From the Sleep settings screen click on Turn On Automatically. Toggle the time at the top of the screen to off.  Toggle on "Time Period" at the bottom of the menu instead.  This will activate the mode but not the alarm. Problem solved! This has worked for me and not triggered the alarm daily. Best of luck!

Screenshot_20230221_223034_Modes and Routines.jpg

Pearlietang
Apprentice
Options

Trying this tonight hopefully it works! On s23 ultra 

Sazzles
Journeyman
Options
I resolved this, by creating a new Mode and not using the pre-created Sleep mode.
You can't use a bed motif for the mode, and there isn't anything else that is all the suitable, but that doesn't matter to me. I have a mode that does what I need it to and most importantly doesn't insist on waking me up on my days off!!
0 Likes
Sazzles
Journeyman
Options
Haven't read back over the other comments, but I resolved this, by creating a new Mode and not using the pre-created Sleep mode.
You can't use a bed motif for the mode, and there isn't anything else that is all the suitable, but that doesn't matter to me. I have a mode that does what I need it to and most importantly doesn't insist on waking me up on my days off!!
0 Likes
Stuart13
Apprentice
Options

Same issue with A33 5G. Why Samsung has to impose a buggy skin over perfectly good Android escapes me.

JonnyP99
First Poster
Options
This worked a treat - still had to go and delete the auto routine again for some reason and also now annoying bedtime alarm gone from clock - thanks
0 Likes