Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

Sleep mode keeps activating alarm no matter what

(Topic created on: 21-02-2023 01:51 PM)
VinMar
Explorer
Options

Sleep mode keeps activating the alarm no matter what I do. I have gone into the settings and dug down to turn it off and saved it but it reactivates next time. I deleted the current sleep mode then rebooted the phone and recreated it turning off the alarm but it still insists on turning it back on. I've stopped the app cleared the cache pretty much everything I could think of and it persists.

I've finally deleted sleep mode completely and just use the do not disturb under notifications and it's no problem. If you have other options you want to change during do not disturb most can be written into a routine that runs at a specified time period you can set parallel to sleep mode. Sure it's a pain but less painful than the bug that keeps arming the alarm.

Samsung you need to fix this.

73 REPLIES 73
RazzleDazzle3
First Poster
Options

Same! The do not disturb doesn't really make a difference to me, I'm still getting notifications, it's just silent. Having the automatic dark mode and shield is what I care about, and this stupid alarm is killing me. I set up sleep mode to last longer than I sleep because I don't want to wake up to a super bright screen and sometimes I can sleep in. I just can't believe they'd make a setting you can't change, as if absolutely everyone uses their alarm on their phone or wakes up at the same time each day or can immediately wake up and look at full brightness. What a weird assumption to make and what a weird feature to lock

Zerosandones
First Poster
Options

Everything about oneUI is buggy. I came from a pixel 6 where all these features worked flawlessly. I have no idea why Samsung insists on breaking perfectly good software by injecting their nonsense.

Please fix this! And make it so bedtime mode turns on consistently at the correct time. Sick of half assed workarounds, when stock android doesn't have any of these bugs. 

0 Likes
laxet
First Poster
Options
Broken for me too. Woke me up on a Saturday morning bright and early, thanks Samsung!
0 Likes
Morganic
First Poster
Options
Got woken up at 7am this morning, I was up all night with my newborn and absolutely deep in sleep, so angry
Dasherton
Apprentice
Options
Try creating a routine that is triggered by sleep mode. The routine turns off the alarm set by sleep mode. Obviously a workaround not a proper solution.
Members_uvYeya8
First Poster
Options

Hi VinMar, you say "read earlier post". Could you point-out the solution please? (many people, as myself, are still looking for a solution in this topic).

0 Likes
mangojelly
Journeyman
Options

So I think I found the cause of my issue and solution. I think it was related to my Galaxy Watch 5 Pro syncing "sleep" mode with my phone. I disabled the sync from my watch. This might fully fix the issue, but I also turned off my "sleep" routine on my phone and created a custom routine that essentially had the same settings. An alarm hasn't auto turned on in the past few days.
Still a workaround until Samsung fixes the root issue.

0 Likes
Solution
VinMar
Explorer
Options

As previously stated a couple times in the posts there is only a work around.

1: Delete sleep mode completely

2: It you want a "Do Not Disturb" turn it on under notifications.

3: If you want to change system settings such as greyscale etc. during DND time create a routine to do so.

You need to know how to use your phone I'm not giving a step by step in a post.

0 Likes
CodeApe
Journeyman
Options

Also have a galaxy 5 watch, is this the common theme..?

0 Likes
skwirrel
First Poster
Options

Thanks for the workaround solution. However, several users talk about using DND instead. In my opinion, sleep mode has a different purpose than DND. I don't want to just not be disturbed (especially by an alarm). As a solution this defeats the purpose of sleep, and if Samsung doesn't fix this then 'sleep' mode may as well not exist.