Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

S21 ultra stuck on 120 Hz and draining battery

(Topic created on: 30-01-2022 09:15 AM)
BroTony
Journeyman
Options
My S21 ultra is constantly at 120 Hz it doesn't even switch to 60 when watching videos. This has a huge toll on my battery. I'm getting 5 hours of battery when I used to get around 8. I'm using the exynos variant in the UK btw,unlocked. I had the January update on 13 Jan. 

1 Solution


Accepted Solutions
Solution
GoanGeek
Samsung Members Star ★
Options
Mine is fine.

YouTube - 60htz
Disney + - 48htz
Netflix - 48htz

And standby 60 htz.

I have noticed since Android 12 You have to keep doing a wipe cache and repair apps( in same menu) after every update.

Atleast that's what's helped me.

Good luck.

View solution in context

15 REPLIES 15
xSteveuk
Mastermind
Options
Hi,
Try going settings
And search for
Motion Smoothness
Tap on it
And set to
Standard
60Hz
BroTony
Journeyman
Options
Hi. I want the 120 Hz,for smoothness. The 120 Hz is supposed to be adaptive right. Its supposed to drop based on what I do. I have the "show refresh rate" on and it's always on 120 Hz. Even when the screen is off. That's my problem. It isn't being adaptive. I just can't deal with using my phone at 60 Hz that's why I don't wanna use standard smoothness.
0 Likes
BroTony
Journeyman
Options
As you can see,it still runs at 120 Hz. It used to be 48 Hz Screenshot_20220130-093107_Samsung Members.jpg
0 Likes
Solution
GoanGeek
Samsung Members Star ★
Options
Mine is fine.

YouTube - 60htz
Disney + - 48htz
Netflix - 48htz

And standby 60 htz.

I have noticed since Android 12 You have to keep doing a wipe cache and repair apps( in same menu) after every update.

Atleast that's what's helped me.

Good luck.
BroTony
Journeyman
Options
Thank you I'll try that
0 Likes
Options
Well that's definitely a problem but not really because we have screen time and it can give us a head ache And you should at least be greatful that they came out with the ultra
jayboi54
Voyager
Options
Mines the same stuck at 120hz
0 Likes
jayboi54
Voyager
Options
Just done that and seems to be OK now, thanks
BroTony
Journeyman
Options
This worked