Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Echo on recipient side on S21 only in speakerphone mode

(Topic created on: 05-12-2021 05:09 PM)
dmo
First Poster
Options
Galaxy S21 Series

I have a brand new Galaxy S21 and when I am speaking to someone on the phone, if the phone is in speakerphone mode, the person I am calling hears an echo of themselves. I do have a phone case (Speigen liquid crystal case) that is on the phone. Is the case the reason? 

 

Any help is appreciated, I do like to use speaker mode quite a bit.

6 REPLIES 6
xSteveuk
Maestro
Options
Galaxy S21 Series
Hi,
Try below
Go Settings - Apps
Look for Bixby Service
Storage
And just clear the cache

Bixby uses the mic also
And see if that helps
Resolves the echo

Also When on samsung members page
Run a diagnostic test
Clicking on the get help button
Mic test

Failing that perhaps a reset
(((Backup phone if do reset)))
0 Likes
GoanGeek
Samsung Maker ★
Options
Galaxy S21 Series
Obviously they will hear themselves as they can hear it from your speaker phone .

Better to you use a Bluetooth head set or without speakerphone.

It would be same if they put you on their speaker you will hear yourself as well.
0 Likes
ishearman
First Poster
Options
Galaxy S21 Series

umm no, no you wont.  plenty of people use speakerphone without any echo or hearing themselves.  no one would ever use it if that were the case.  the microphones + software has the ability to filter out your voice from being played back.  if your speakerphone is functioning normally, even if both callers are on speakerphone at the same time, there should be no echo.

restarting the phone can fix it temporarily.  others have had luck with clearing the cache of the phone app.  Just did a call, both of us using s21's, both on speakerphone, zero echo for either of us.  we are using the stock samsung phone app.  haven tried with google phone app.

TB13
First Poster
Options
Galaxy S21 Series

Did you ever find a solution for this? I'm trying to fix this on my phone, so I don't have to RMA and switch to my backup phone.

0 Likes
MKBStudio
First Poster
Options
Galaxy S21 Series

The only effective fix I've read and tried is to remove your case.  This still doesn't explain why the problem happens sporadically.  But every time someone tells me they hear an echo, if I remove my case and call them back it is fixed.  REALLY annoying.

Mark555
First Poster
Options
Galaxy S21 Series

After living with this problem for over a year, I finally found a real solution that seems to completely resolve the problem. None of the other things I found worked and I am unable to disable wifi calling (as some suggest), because I need it in my house due to cell tower reception limitations. 

Anyway, the solution is to go to Settings\Advanced features and disable "Video call effects" and reboot. I have no idea how Video call effects are related to this problem or why this was the magic fix for me, but I really don't need that feature anyway. I thought I would post this information because I had such a hard time finding it and wanted to share to help others as frustrated as I was.

0 Likes