Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

S20 FE 5G unable to see 5ghz wifi ssid

(Topic created on: 23-02-2023 01:51 AM)
4523 Views
Romster
Explorer
Options

 y S20 FE 5G  doesnt seem to see any 5 GHz   wifi networks. did a search   and others have  posted about this issue too. wondered if anyone has this issue and a  solution. im  running android 13 with the latest UI I can  only connect  to the 5 Ghz  wifi if i  add the network manually but even the it doesnt stick  so doesnt appear in available networks when i    go back to try to connect to it again after   disconnecting. verty  annoying especially as the S7 which i  previously had  never had  an issue seeing both wifi channels on my home   wireless network

0 Likes
10 REPLIES 10
Romster
Explorer
Options

the  issue is caused by the channel number which is being used by your router for the 5Ghz band. All of my other android devices and windows ones too see and are able to connect to my wifi's5 Ghz network Samsung'sS20 phones  seem to be limited  as to which channels they can see and use. There are numerous people globally having this issue so can only hope that a fix ( patch) for the Wi-Fi connection stack will be rolled out.  Till then the only way to  view and connect to  home 5 Ghz Wi-Fi is to  change the channel  for the 5Ghz band on your routers. ive tested and made the change and now my S20 FE 5G sees and connects automatically to the5GHz Wi-Fi network

vrmadd
Apprentice
Options

What channel do you need to set the router to for the 5G wifi to work?

 

cj4331
Student
Options

So what channels work?

0 Likes
vrmadd
Apprentice
Options

I recently updated the Samsung software, and now it seems to see the 5g networks.  I'm not sure if this was the fix or just a coincidence!  Android v13, One UI v5.1

 

0 Likes
vrmadd
Apprentice
Options

Well the fix didn't last.  Back to 2.4ghz wifi only.  Samsung needs to come up with a fix. 

0 Likes
JohnPHartshorn
Apprentice
Options

Channel 36 worked for me.  Then going back to Auto the connection stayed (presumably staying on 36).

0 Likes
JohnPHartshorn
Apprentice
Options

I'm on that same version and had the problem.  I forced to channel 36 rather than auto and got the 5Ghz connection back.  I then went back to Auto, and the connection stayed.  Maybe a hiccup, maybe one channel not configured correctly in OS.  Time will tell.

0 Likes
cj4331
Student
Options

I got it working--not sure how.  But, I went back to 2.4g as the range on 5g really sucked.  I found my speed over 2.4g was faster than 5g once I was a room away from the router.  No biggie--now I know.

0 Likes
rchelpka
Student
Options

This issue is clearly not fixed. A simple reboot of the phone usually resolves the 5G SSID visibility problem but it is only temporary and it ends up reverting to only 2.4G. It's pretty disheartening that Samsung is seemingly ignoring this. 

0 Likes