Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

I cannot get Roaming clock to show

(Topic created on: 27-07-2023 06:48 AM)
13383 Views
Bilfrost
Apprentice
Options

Samsung S20+, android 13.

I have set roaming clock on, including on Always on display. 

My local time zone is set to Eastern time. 

I am in Central time. 

Yet my home time is not showing, only local time.

 

0 Likes
11 REPLIES 11
AndrewL
Moderator
Moderator
Options

@Bilfrost: Can you try heading to Settings > General management > Date and time, and toggle on 'Automatic date and time' along with 'Automatic time zone' to see if this helps? 

If not, please head back to Settings > Lock screen > Roaming clock > Toggle this off, then on again, then set your Home time zone below. Please note that this feature will only function as expected if you are currently outside your home time zone, and if it differs from the time zone of your current location. 

0 Likes
Bilfrost
Apprentice
Options

Thanks. I have it on auto time zone. I did try turning roaming on and off. Still only seeing one clock. 

0 Likes
Bilfrost
Apprentice
Options

Update: i noticed that for AOD, there is a clock face where i can add a second clock and select the location. This partially solves my problem. 

This clock shows even if i turn off Roaming clock.

So as of now, these are my observations:

1. The roaming clock button doesn't do anything at all 

2. AOD has a clock style that allows showing dual time. This is independent of the roaming clock button

3. There is no way to show dial clock on the lock screen. 

Bilfrost
Apprentice
Options

Another interesting fact. I was close to the border and my phone picked up Telcel (Mexican carrier). At this point, the roaming clock showed up. But as soon as my phone switched back to a US carrier (not even T-Mobile, which is what I use), the roaming clock went away. 

So, makes me wonder, by "roaming clock" does Samsung really mean roaming internationally, rather than a time zone that is not my home time zone?

mariano_s
Student
Options

I'm having the same problem, it stopped working for me, it was working a month ago so i think it's the new update 

Members_wm8xGv1
First Poster
Options

I have the same problem, it was working before but does not work now. My home time +3, last half year I locate in Asia and nothing changed in my location

0 Likes
Members_pcWY2uo
First Poster
Options

So for me it appears to take as "locale" whatever is locale for your carrier.

It just ignors your "home time zone" until you are "roaming" with a foreign carrier.

At leat that is what i experience. When changing to a locale SIM my roaming clock disappears, and i cant get it back until i change to my "home" sim. Very annoying.

0 Likes
Potet
First Poster
Options

I've been able to confirm what the previous poster describes:

Samsung uses the locale of your "Preferred SIM for Calls" to decide if you're "roaming" or not.

In my case, I'm using an eSIM abroad so it was very easy to test: if I update my SIM settings to use my home SIM for calls, I see the Roaming Clock.

If I set my eSIM as my preferred SIM for calls, the Roaming Clock disappears.

It doesn't seem to care if I have Roaming Clock enabled.

vik100
Student
Options

Thanks @Potet - this resolved the issue for me.  In my case, it was using a second SIM (not eSIM) and setting that to the preferred SIM for calls.  

As soon as I reverted to my original home SIM 1 card for calls, the roaming clock returned again on my lock screen

It also seems like you cannot use the "Ask always" option sadly and keep the roaming clock

0 Likes