Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

Keypad and DTMF tones not working during a call

(Topic created on: 28-05-2019 11:06 AM)
taffw
Apprentice
Options
Galaxy S10 Series

Hi,

I have a new Samsung Galaxy S10 plus and it seems to be upto date with all software. basically during a call the keypad and DTMF tones don't work, so when i'm through to say a call centre when it says please enter option 1 or 2 etc, it doesn't register at all so very frustrating. I did a chat with Samsung and tried all the things he suggested but nothing. He then said well you will have to contact our Samsung Web developers !! which is frankly quite dissappointing. It still isn't fixed and means I can't do thing like contact my bank or enter payment details during a call. I've come over from Apple and so far not impressed at all. Does anybody have the same issues or any suggestions. i'm on Vodafone. This to me is basic called but it doesn't seem to work or is my phone faulty?

1 Solution


Accepted Solutions
Solution
SuperPhoneWizar
First Poster
Options
Galaxy S10 Series

Real true actual working solution:

1) Try all of the above methods excluding the one involving installing a phone app

2) Each time test it by phoning relevant number

3) By now you've run out of airtime. Go buy some more

4) Now turn your phone off

5) Now turn your phone on

 

That fixed my problem. For you? Who knows...

View solution in context

70 REPLIES 70
JoJo1179
First Poster
Options
Galaxy S10 Series

Hi,

 

I had the same on my phone. If you go into settings and search for dial tone you need to make sure dialing keypad phone is on. Mine is now working since I changed this setting. 

MVP
First Poster
Options
Galaxy S10 Series

I turned that setting on, but there are still no DTMF tones in my calls.

AndrewL
Moderator
Moderator
Options
Galaxy S10 Series
I'm not sure if this is what @JoJo1179 was referring to, however you could try going to Phone > Tap the 3 dots in the top right > Settings > Play Keypad Tones > On, to see if this helps.
MVP
First Poster
Options
Galaxy S10 Series

I checked that too.. it's actually in 3 dots -> Settings -> Call Alerts and Ringtones -> Play Keypad Tones.
Th option has always been set to ON, and still no DTMF tones on this stupid phone.  I turned it off and on agian to no avail.

 

wyse_terminal
Pathfinder
Options
Galaxy S10 Series

Give the gold contacts of the sim a wipe if this does not work then try a replacement sim this should do the trick. 

0 Likes
Johnny8
First Poster
Options
Galaxy S10 Series

I have the same problem on my S10. The tone is audible but so short that the automated system on the other end doesn't detect it. It's always that short even if I long press on the number in the keypad. I haven't found a solution yet either. This is my first Samsung phone and may be my last if I can't make this work. 😞

Couchman1
First Poster
Options
Galaxy S10 Series

Is there a solution to this?

 

Been oi n phone for 1 hour to Samsung and still not working.......

 

So frustrating as you cant even call their customer service without options which you can't not press!

Isacco1975
First Poster
Options
Galaxy S10 Series
Disable the AntiSpam call filter!
I had the same problem with my home banking. I disabled that filter, and finally worked fine!
0 Likes
SuperbBandit
First Poster
Options
Galaxy S10 Series

Turn the volume up on your phone. If your phone is in silent or vibrate only mode the system volume is also muted. This worked for me.