Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

WhatsApp is not ringing when screen locked

(Topic created on: 08-06-2022 10:39 PM)
Saabina
Journeyman
Options
Galaxy A Series

Hi I’ve just bought a Samsung A13 and WhatsApp is not ringing when screen locked.  I’ve checked notifications are turned on for the app.  Uninstalled and reinstalled WhatsApp.  Normal calls ring when screen locked so only affecting WhatsApp.  Can anyone help please?

0 Likes
3 REPLIES 3
Ventor
Samsung Maker ★
Options
Galaxy A Series

@Saabina Hello, access the Whatsapp app settings / Notifications / Calls, verify that you do not have a silent tone set.
In phone settings: Access Settings / Applications and search for Whatsapp. Within the options / Notifications / Notification categories / below everything - Call notifications. Click on the letters and you will see more options. Show notifications and Sound must be activated.Check in Sound -that is not in Silent. Greetings

0 Likes
Z80_Man
First Poster
Options
Galaxy A Series

Hello,

There's no such thing as a silent mode nor any ringtone volume setting in the Calls section (nor any other one actually) of WhatsApp notifications settings.

There's only the ringtone currently in use (apparently, the same as the current phone ringtone, a choice for an external app to be able to change it appears when pressing on the "Ringtone" line) and a vibration mode setting offering four choices (from "Disabled" to "Long"), and that's all.

WhatsApp definitely seems to be using the current "Media" volume rather than the "Phone" volume, EXCEPT, as Saabina first explained in the original post, when the phone is NOT locked.

As a matter of fact, I always keep the "Media" volume disabled so that I don't bother people around while checking social media or playing games, because noisy ads tend to pop up without notice (plus their own sounds are unwanted as well).

As a result, that's only when WhatsApp's would ring loudly on incoming voice calls (still with the media volume completely off, but of course the phone volume on). However, as mentioned above, it's completely mute when the phone is locked, so it only vibrates, and as a result, I miss incoming calls most of the time.

 

As for the Call notification section in the general phone settings, everything is enabled normally, so that's not the problem.

 

I think the actual problem is exactly like Saabina described : incoming voice calls in WhatsApp only use the Phone call volume when it's unlocked, and seems to be using the Media volume instead when it's locked.

Which is utterly stupid IMHO, and would need to be changed, but can most probably only be done by WhatsApp themselves and not by Samsung.

HTH

0 Likes
emre74
First Poster
Options
Galaxy A Series

Issuing the same for some weeks on my new Galaxy A33. I tried every possible setting you could find on Google. Including a factory reset. It looks like it's fixed, but the same problem reoccurs after some while. Only disabling the screen lock was a solution, but I need the protection level for my apps. I am a big Android fan, and this is my first experience with Samsung. For the first time, I wanted to break a device and throw it away. Such a waste of time, nerves, and money. Never again.

0 Likes