Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Galaxy A53 wifi slow

(Topic created on: 19-11-2022 06:37 AM)
9208 Views
clockley
Student
Options
I have an issue with my A53 getting very slow wifi connection. I have 1gb broadband with but only get speeds around 28mbs coming through on speed test. My old Galaxy A50 still gets around 400mbs. This is so frustrating as basic website take a long time to fully load. And I may aswell forget youtube or other video sites as fhd videos don't even load.
Does anyone else have issues with this or have a fix idea that I can try ? I have already tried all the usual troubleshoots that samsung advise.
Thanx
17 REPLIES 17
Jake111
First Poster
Options
Same issue, WiFi speed starts to slow after bit, turning the WiFi off then on again fixes temporarily. Samsung A53 also, bought new in March
0 Likes
AlanS5325
First Poster
Options

Came here with the same issue. Tried rebooting cable modem, router, and even rebooting the phone... Still 35-39Mbps on SpeedTest app, while my wife stood next to me with her iPhone 14 and got 239Mbps. THEN I simply turned the A53's Wifi off & back on again. Retested at 254Mbps!

0 Likes
AlanS5325
First Poster
Options

Try turning the phone's wifi off and back on again. Worked for me! Went from 35-39 Mbps to 254 (which is about the best we get out of our home Wifi).

0 Likes
Tommy7619
First Poster
Options

Good for you, sir.... Too bad, it didn't work here... Already restart the modem, the router, the wifi, even the phone itself... No luck

0 Likes
sunnyda
First Poster
Options
Not being a techie haven't tried much. But when I reboot phone I briefly get proper speed of 70 to 80 maps but usually it is less than 10 on my phone. WiFi itself is fine x box plays well .
0 Likes
Bear68
First Poster
Options

So, did ANYONE (Samsung perhaps) come up with a working solution to this issue? Using A53 5G (because it came with my wife's phone) which runs ridiculously slow on wifi. Seems it only connects to the 2.4GHz side, even though I'm only in the next room to the dual band router. Can't turn off bluetooth as  I use a Constant Glucose Monitor than needs bluetooth, so that isn't an option. EVERY other device works fine on the router. Have reset router, phone, deleted network settings on phone and started again, only solution so far is to turn off wifi and use mobile data. Phone is 7 months old.

0 Likes
ammar233
First Poster
Options
I have the exact same problem with my a53
0 Likes
liteglow
Journeyman
Options

I have the same problem .

and the SOLUTION : Buy a Huawei P40PRO .

 

actually every other phone in the house work, even my old NOKIA N95 with Wifi works better.

 

why is there no update from Samsung ??

0 Likes