Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Galaxy A40 Android 11 One UI 3.1 Wifi problems

(Topic created on: 11/05/21 21:23)
spangaer
First Poster
Options
Galaxy A Series

@Samsung

First, @Samsung. Your hardware support  is great. I had an issue with a camera over the summer and you picked up the phone, fixed it an brought it back within 48 hours. Having to do the  factory reset was a bit annoying but OK.

Your software support is living hell on the other hand. It's completely geared towards "user error/ clear some caches / get better signal". I sort of understand that's what first level support is all about. (suggesting a factory reset at that point, really unkind, glad I didn't go there...) If a Google made you do all of the reasonable things already, it should be possible to log a bug, right? Can't do it via your members app, not via WhatsApp. The person I called claimed to register it but I'm 99.5% certain it went nowhere. The only e-mail I got concerning the subject was a satisfactory survey. -> Not quite satisfied...

The problem

(This to help out Googlers)
So after my Android A40 got upgraded to Android 11 One UI 3.1, my WiFi got horribly unstable. Specifically when connected to certain WiFi access points in my home (TP-Link TL-WA801ND). After Samsung reading my system logs multiple times.  The first couple of response where completely besides the point: "weak signal". The access point had worked all this time with the given load and kept on doing so on a Samsung A41, which is at A10 O-UI 2.5. All of them where on the same floor, only brick walls in between and distances of a couple of meters at most.

Analysis

One response (really only one) gave me something something to go-on, pulled from my log:
Disconnect reason 3: Deauthenthiced because sending STA is leaving (or has left) IBSS or ESS.
Only the suggestion to "please use wifi with closed distance" -> Grrr... Grrr... Grrr... 

While weak signal (because of long distance) could probably cause that, that wouldn't be the case here (which I had clearly stated while reporting). Some Googling of that specific WiFi error did give some suggestions of DHCP errors potentially causing that.

What I have noticed is that Android + TP-link WiFi almost always seem to fail distributing IPv6 addresses.  (I have TL-WR841N in AP mode, suffering the same). It looks like TP-link firmware borks that somehow, because when connecting to the ISP router WiFi it hands out IPv6 addresses just fine. Connecting with a Windows laptop also seems not to suffer that problem, but when combining Android + TP-link Wifi, DHCPv6 seems to go horribly sour.

Be that as it may, Android 5, 9 and 10, never made any fuss about that. Just used the IPv4 stack and otherwise worked as expected.

So my guess is something slipped in to Android 11 (I've seen plenty of other brand phones having similar issues), that made it decide (in certain cases) that it should have IPv6 connectivity and if it doesn't it ditches the connection. I think it doesn't do this if there's no hint of IPv6 available. E.g. my guest wifi has none of that. But with the access points the phone talks to a router with which it can use IPv6 sometimes but it fails almost always when going over the TP-link AP's.


My take. Yes, the root cause is probably the AP's but that doesn't mean that the intolerance of Android 11 is not a regression. I was just trying to log this as a bug. I'm not even blaming Samsung here (other then not wanting to listen). It seems Samsung, as largest Android vendor, would have a seat at the table to get this fixed upstream.

OpenWRT to the rescue

Given

  1. It's impossible to log a bug, so getting this fixed on the A40 wasn't going to happen anytime soon.
  2. The disconnects where quite bother and I need that AP to have signal at certain places
  3. It's presumable that TP-link firmware isn't all great
  4. OpenWRT seemed to offer a way out there (whoohoo TP-Link TL-WA801ND v5 support is documented excellently).

After ensuring a spare (remember the TL-WR841N 😉 ), I got to my AP's to spin an OpenWRT 19.07.x. (in case anyone wonders; I did; the stable build contains LuCI, so config is dead easy).

What do you know, both an Android 5 as my A40 Android 11 have solid IPv6 support and with that, all instability seems to be gone. I haven't seen any involuntary disconnect since. Even in worse signal conditions then usual usage.

Truth be told, I'm looking at IPv6/DHCPv6, because that was an observable difference between the WiFi connections and other Android 11 users seemed to suffer problems in this area too. There's a chance, that there's some other bug that OpenWRT fixes, that avoids Android 11 from tripping.

But changeing the router firmware is the only change. So same hardware in the same location. Hence, it seems like I was rightfully frustrated over any "weak signal" arguments.

Conclusion

While I still have a feint hope Samsung actually picks this up and pursues it. I've mostly written up so that others suffering from the same have a chance.

Special thanks to the OpenWRT peeps btw! You're great! Really don't understand why TP-Link sticks with their buggy bazaar, if you can make those devices so much better with what you make. ❤️

0 Likes
0 REPLIES 0