Support

Open search

A70 screen will not dim/USB connection.

Highlighted
Apprentice

Hey,

 

I've noticed a problem with my A70 regarding trying to dim the screen when locking manually or expecting it to lock after screen timeout.

 

Basically, my phone won't sleep, at least not whilst charging. I spent a good while playing around with settings on my phone, such as timeout and lock screen settings. I also powered off the device but no luck.

 

After trying to figure out the problem further I discovered that the notification tray is being constantly updated every few seconds swapping between "Android system USB connector connected" and "Android system USB connector disconnected". So presumably this is what is keeping the phone awake as it thinks it is being constantly connected and disconnected from source USB source. I cleaned out the USB port but it was pretty clean to begin with. I'm not getting any notifications regarding any moisture detection.

 

The A70 charges just fine (though sometimes there is a slight delay to it recognising being plugged in) and it seems that the USB tethering interface is working well as I can use the remote debugging feature in Google Chrome (for web development purposes) just fine. As far as I can tell, there are no actual issues with the USB port - it functions as I would expect.

 

The A70 was last updated on the 14th August to "Security Patch level: 1 July 2019" and looking over the log of updates I see that "The charger/USB port's moisture detection algorithm has been improved" - so someone somewhere has been looking at this feature and I doubt it coincidence that my device has just developed a fault, given that I've not had it anywhere near moisture or excessive dirt.. and the port still actually works!

 

I've also tried Safe Mode but the issue persists. Also, if I power the device off, then plug it into the wall, power it on, the notification issue stops... until I unplug it/switch off the wall socket - then it comes back again.

 

Anyone else having similar problems?

550 REPLIES 550
Highlighted

Can you please say if you have found an answer as I have the same problem and its driving me mad !!!

Highlighted
First Poster

Mine has the same problem!! How did you fix it ??

Highlighted

Hello,

 

I had the sub-board replaced in mine. Samsung ran diagnostics in store on my phone which flagged up on a software issue, not hardware, so they flashed the latest update to the phone again but that didn't fix it. I took it back and they tested it with a volt and amp meter and that showed that charging was inconsistent and below what would be expected so they explained that perhaps the port and the sub-board needed replacing. I asked Carphone Warehouse to replace the port (that's where I bought the device) and they replaced the sub board. That was about a week a go and the phone has been fine since. It was covered under warranty.

 

I do still find it hard to believe this is just a software problem given how many of you have the problem as well...

 

Good luck.

Highlighted

I turned off notifications and generally fiddled with settings which seemed to stop the USB connection on/off issue from waking up the lock screen, though the issue was still there, but at some point that stopped as well and at the moment the phone is working normally.

I too bought from Carphone Warehouse but haven't had any boards changed. It's all a bit inconclusive and I wouldn't be surprised if the problem re-occurred since nothing I did seemed to make any difference at the time!

If it is still in warranty, take back to,the vendor and make it their problem, that is what they are for after all.

Best of luck

Highlighted
First Poster

I have same issue , please Samsung fix it ! !

Highlighted
Observer
I'm having this issue as well. For a week or so, it was giving me a constant "moisture detected" message, then that mid-August update came along and fixed that. However, this started happening a few days later and now it's constant, screen will only turn off at all if it's on charge. It was on and off at first but now it seems to have "settled" into being all the time. Not sure if it's just in my head, but the touch screen around the bottom also feels a bit less responsive - suppose that might make sense if it thinks it's being plugged in then unplugged every couple of seconds.

I can't figure out how to turn off the USB connector connected/disconnected message/notification unfortunately. Going to head to my nearest Samsung Repair Centre over the next couple of days - was waiting until this happened consistently enough that I wouldn't risk going in only for it to be working perfectly!
Highlighted

I have this problem as well.

 

Only one person reported it was fixed after doing a software downgrade/hardware replacement, so which is it?

Can anyone else report what they did to fix it?

The lab's guy already told me that it's 110% broken hardware and I should pay for that but I'm sure it's not, now go prove it... I'm about to go there later today...

 

Thanks

Highlighted
they fixed my phone to, SUB modul and flex modul was replaced (sorry for bad english)
Highlighted

Thanks!

what do you mean by this "SUB modul and flex modul"? 2 hardwares?

Highlighted

I had the exact problem where it shows android system message, connected/disconnected and kept my screen turning on while it's not charging. I found out that there's an app called "Always On Display" by Samsung, I think it's a new thing. I force stop it and now the screen is turning off. Hope this is your problem! :smiling-face:

Top Liked Authors