Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Cellular missing on Book 3 pro 360 with Giff Gaff Sim fitted

(Topic created on: 13-04-2024 01:15 PM)
126 Views
Members_DbX3oRZ
Apprentice
Options

I have recently purchased a refurbished Book 3 pro 360 which has a sim slot for the 5G cellular module. Although the Intel 5G solution 5000 card shows in Device Manager and on the Control Panel Adapters page, it will not enable and ther is no 'Cellular' shown on the Netork and Internet settings. I have been all round the houses with Intel support and updating drivers, uninstalling and re-installing etc and finally Intel have washed their hands of it and have said as it is installed by Samsung it must be a Samsung software / hardware problem! Have tried other known 'good' sims in the slot, but nothing seems to register with the Windows 11 pro I have running (It didn't work with the original 11 Home when I received the laptop). Internally, everything seems 'seated' ok and all cables firmly attached. Have run out of ideas as to what to try next!! 

Any help would be much appreciated!

5 REPLIES 5
Members_DbX3oRZ
Apprentice
Options

Hi. Still no joy withtrying everything to bring the 5G mobile side to work. Not certain whether it is the cellular 5G M2 board at fault or the Sub Board. The only spare 5G boards I can find are from Digicare for £180. A bit much to fork out on the chance it is the mobile board and not the Sub Board!! Device manager says the 5G is working, but in the 'events' tab of the properties it does say the WwanNet (M80) needs more setup (how?). I've tried downloading the drivers (again!) and reinstalling afresh, but no joy. The 5G board appears in the Device Manager, but where should the 'SIM' appear? Device Manager, Explorer, Settings, or elswhere? No signs of it anywhere! There seems little 'out there' on this topic - and the Samsung website is pretty basic answers and then 'book a repair'. Having worked in electronics for 40 years I don't get worried about 'diving in' to repair, but useful information seems a bit like chicken's teeth!

Again, any assistance would be most welcome!

0 Likes
pittmuir
Journeyman
Options
I've got the same issue ! Samsung any ideas ?
0 Likes
Members_DbX3oRZ
Apprentice
Options

Do any Samsung engineers read these queries? I'm obviously not the only one having this problem, but no help or solutions forthcoming!

0 Likes
Amintnp
First Poster
Options

Same Issue please share the Solution!!

0 Likes
Members_DbX3oRZ
Apprentice
Options

Still no solutions or response from samsung. Tried a different modem card (BA92-22934A purchased for £30 - cheap, so don't know how healthy it is) in place of the installed BA92-24246A, which booted up, but wasn't happy in the system (ended up crashing things). Went looking for drivers for this other board, but got no fresh suggestions to try. The Samsung website just gives basic suggestions to try and then 'book a repair'; there doesn't seem to be anywhere on their site to go and look for 'the latest drivers' for particular devices or a list of the latest versions. Tried the Microsoft update catalogue, but none of their download drivers worked. In the 'events' tab of the 5G solution 5000 the latest event says the drivers are loaded, status '0', but not sure if this is changeable to '1' to activate them (change a registry key?), so no further forward there. Still of the impression the WwanNet(M80) drivers are not loading as needed.

Still banging my head against the brick wall!!

0 Likes