What are you looking for?

Showing results for 
Search instead for 
Did you mean: 

ActionDirector won't activate

(Topic created on: 07-04-2018 10:20 AM)
First Poster

I downloaded and installed Gear 360 ActionDirector and when I ran itand went to 360 video, it asked to connect my gear 360 to my pc for activation. I did then I get an error message


Activating now...

Gear 360 ActionDirector was not activated because a connection to the activation server could not be established. Check your internet connection and then try again.


My internet is fully working and I have no problems connecting to anything else. I even disabled the windows firewall and sitting open here and I cant get it to work.

First Poster

I'm getting the same too.

disabled firewalls and rebooted several times. says there is no connection to the internet even though I'm connected while typing this.

What is the use if I cant use the software ??????


Hi guy's,


None of you are doing anything wrong. The gear 360 application takes your serial and checks it with samsung, Or rather it tries. If you don't like or get technical jargon feel free to skip to the summary - in short you're doing nothing wrong and it's all samsungs fault.


Gear 360 sends out the following request to samsung when you enter a serial - The text "SERIAL" is a place holder for my or your actual serial.



POST /keydownload/c2?device_num=SERIAL HTTP/1.1
User-Agent: ActionDirector
Content-Length: 0
Pragma: no-cache
Connection: close



This request is sent to If you try to visit it you will find that the domain does exist but your browser dows not display anything. Looking at the whois information that was provided when the domain was bought, It was registered by "Samsung Electronics CO., Ltd" on 2008-11-27T23:43:47Z. The domain registration was last updated on 2017-10-30T04:43:31Z. That domain is due to expire on 2018-11-27T23:43:47Z.


This means the domain was bought in November 2008 and Samsung actively maintained their ownership of the domain again in October 2017. So, Why isn't it working???


Well the request that is generated by the gear360 does not recieve any kind of response where as a request sent to the same resource ( from a web browser does recieve a request.


Unfortunately the response I recieve back from the samsung key server lets me know that the application that they SHOULD be running to give people their keys, Does not exist. As shown in the screen shots below which shows the failed request made by the app at the top and the successful one made by a web browser to the same resource.

Failed request by app and successful request from browser showing non existance of validation app on samsungs serverFailed request by app and successful request from browser showing non existance of validation app on samsungs server

This is due to there being no DNS record on samsungs authoritative nameserver for the host that the app was told to look for. The app tries to request from and there is only a record for The request made by the app can be seen to generate a response when the host is altered to reflect this.


Now if this were the only problem I give everyone a fix for this, however, There have been more failings on samsungs side. As I mentioned before the resource "" does not exist on samsungs server. It was responsible for verifying users serial numbers.


request generated by the gear360 app with host altered, host has "www." removed. request now recieves a resonse but it is one telling us that the server has had the componant responsible for user verification removedrequest generated by the gear360 app with host altered, host has "www." removed. request now recieves a resonse but it is one telling us that the server has had the componant responsible for user verification removed


In summary there have been two failings here. One by CyberLink in having the app call a nonexistant domain and not testing the user verification functionality, And secondly by Samsung for removing the capability of that server to verify users.

In order to fix this;

  • CyberLink will need to push out a patch to point the ActionDirector software to the correct domain (
  • Samsung will need to restore the web application to /keydownload/c2 on


Samsung have a responsability to their consumers to provide a means to allow their product to function without a samsung phone. No where on the packaging is there a stipulation that a samsung galaxy is required in order to use the camera. I would ask that samsung provide a means for customers to be able to use the CyberLink Action Director software as soon as possible to prevent possible reputaional damage that may arise from the disclosure of this information. I expect a reply within 2 days, Thankyou.


First Poster

Gear 360 Activation - Possible Fix


If you can't active Gear 360 Action Director

and get an error like the following:

"gear 360 action director was not activated",

or "cannot reach activation server",

you might need to check your

c:\Windows\System32\Drivers\etc\hosts file.

If you have the following two lines,

just remove them or comment them (add a # before the line):

I am a software developer myself, and sometimes,

I really can't even start to comprehend the stupidity

and the incompetence of certain developers/QA testers.

"just_do_it_now"  it work for me.


Thanks! (Unfortunately) I had no such entries in my hosts file... So the problem still exists for me.

First Poster

I'm having the same issue, are Samsung ever going to sort this out. Camera was a waste of money otherwise 😞 

First Poster

Thank you. Had not used my Gear 360 (2017) for years and had same problem.

Else your solution worked for me really needed it. Thanks again

First Poster

i assume there hasnt been a fix?

i have the same issue and now they are stopping support in general for the gear 360 and action cam software  by the end of feburary.


I have wasted days of my life trying to sort this. Let me know if you manage to sort please, I wondered if I buy action director 3 if that will work! It's £40 so It better then owning a ***** ring with a handle!! 


it works bro... holy cowpat's, finally!!