Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

Samsung Q90R Soundbar Right Rear Speaker Fast Flashing

(Topic created on: 08-06-2020 11:46 AM)
Munier
First Poster
Options
Audio & Video

Hello, I have a Samsung Soundbar Q90R. I have manually updated the firmware on the soundbar itself, but not the satellites or subwoofer yet (because it simply won't initiate). I suspect the Rear Right speaker is defective, but since I don't know what normal behaviour is, I don't have anything else to compare it to.

 

My problem is that the Right Rear speaker will not connect and there is no sound. I see the following behaviour:

 

1. When I plug it in, the red light comes on, then the blue light flashes, but a lot faster than the other satellite flashes. Is this normal behaviour, or do both satellites flash at the same speed?

2. When I press ID SET on the Right Rear, nothing happens, no red light, nothing. The blue light just continues to flash really fast.

3. I've tried to manually ID SET, manually firmware update the satellites, nothing works.

4. When I run the test tone (holding in "Sound Mode" on the remote for 5 seconds when Soundbar is off) and no sound from Rear Right.

5. When I adjust the volume levels of the speakers, no Rear Right speaker shows up.

 

I will greatly appreciate your assistance if you know how the Soundbar is supposed to behave and if this is normal.

 

Thanks,

Munier

 

0 Likes

1 Solution


Accepted Solutions
Solution
Ivan1979
Pathfinder
Options
Audio & Video

Bad news...wtf !!!!! Tomorrow I must take main unit (soundbar) and default speaker to the service center !!! I'm so f...... angry !!!!!! Belive me I'm so so angry now !!!!!!!! :shocked-face-with-exploding-head:

 

View solution in context

0 Likes
16 REPLIES 16
Ivan1979
Pathfinder
Options
Audio & Video

Yea,I have the same problem with left surround speaker.. I buy soundbar 02.2020 year and from first day he works perfect till 2 days ago when left surround speaker start fast blinks blue led and after that I cant do nothing to pair again with main station,nothing...Yesterday I call Samsung support and explain to him what happend with speaker and operater take my name and phone number and told me he send email to technical support then call me back with "news"...so I wait the call now...I hope he call me...  :thinking-face:

I think we must wait Samsung for new update softwer to fix that issue...

Only I know that issue is not for bringing to service to fix becouse in owner's manual says when red and blue together blinking then is for go to service...

 

0 Likes
Solution
Ivan1979
Pathfinder
Options
Audio & Video

Bad news...wtf !!!!! Tomorrow I must take main unit (soundbar) and default speaker to the service center !!! I'm so f...... angry !!!!!! Belive me I'm so so angry now !!!!!!!! :shocked-face-with-exploding-head:

 

0 Likes
Gravyboy
First Poster
Options
Audio & Video

Hi. I have the exact same problem. Right rear, fast flashing. LED wont go red when you press the button for 5 seconds. Only red briefly when you turn on the power. Other speaker and sub pair no worries. Tried update etc. I think it is updated. Took it back to the retailer. They plugged it in ( right next to another one which was on ) and it paired immediately! Light went solid blue. Took it home, and it flashed blue slowly ( that was new ) but still wouldnt pair. Tried manual BT pairing again and its gone back to fast blue flashing. What the hell?

Did it pair with the display model instore? Is that even possible?

Soundbar sounds great, shame about tech issues...

 

0 Likes
Ivan1979
Pathfinder
Options
Audio & Video

My Q90R is on service... Main unit and left surround speaker... 🤦‍♂️ 

 

0 Likes
Munier
First Poster
Options
Audio & Video

Thanks for following up Ivan and good luck with your soundbar. It's really pathetic that it's 3 months old and behaving that way. Mine is brand new, straight out of the box. It makes me wonder if I should ask for a new one, or just return the unit for a refund, out of fear that it could happen again in the future.

0 Likes
Munier
First Poster
Options
Audio & Video

Hey Graveboy. Ok, that's kinda surprising and good info to have when I speak with the sales agents, especially if I walked into the store and it pairs immediately! Given Ivan's situation where both the Main Bar and the Rear Speaker went in for a service, it sounds like the pairing with a fast-flashing light is not only dependent on the speaker itself, but could be coming from the soundbar (or at least in its attempt to pair with it). Thanks!

0 Likes
Ivan1979
Pathfinder
Options
Audio & Video

When my soundbar will be finish I will let you know what they (service) must change on my Q90R....only I know service center is waiting for a some parts for my soundbar... 🤦‍♂️ What kind of parts, I dont know for now... I will let you know soon I hope... 

0 Likes
Gravyboy
First Poster
Options
Audio & Video

Mine was also straight out of the box. I guess I will have to take it back to suplier ( again ) and see if it works when not near another one!

0 Likes
Ivan1979
Pathfinder
Options
Audio & Video

Hi.. 

Now Samsung service center call me to get my Q90R... What happen with speaker, I ask, service told me, "we change left surround speaker and we give you one, brand new"... Main station is correct... That's it.. Tomorrow morning I go in Samsung center to take my Q90R soundbar... Finally ! 🤦‍♂️ 

0 Likes