Support

Open search

Gears S3 SM-R760 GPS not working

Highlighted
Apprentice

Followed instructions to the letter. GPS on GS3 did not pick up. Did notice however that GPS on phone was playing up due to possible atmospheric conditions and was not zig zag track than semi perfect egg shape as I walk round a local pond at a measured distance of 1.8km. Will keep playing and fine tuning. Everything else seems ok but early days. Running S7E on Andriod 7.0

Apprentice

Update from yesterday. Connected GS3 to phone to start GPS. If switch off GPS on phone GS3 stops locating. Disconnected from phone and with GPS and Wireless option on GS3 on. Next loaded GPS Reading app on watch to verify location. This app only seems to work on GPS and Wireless. On GPS only it doesn't work. Checked location on GPS Reading on Google Maps and was spot on. Started S health and started walk. GPS located after 1 min or so.

Rebooted GS3 and tried S health again after starting GPS Reader app. It located again after about 1 min or so. 

 

Next tested GPS signal and tracking by keeping it running and leaving it running while out in car doing shopping. GPS on S health held signal and mapped route for at least 10 miles and also while popping in and out of car and shops. Would loose signal in shops as expected and would reaquire signal again when back outside and while in car.

The general idea would he to see how long and how accurately the GS3 would hold signal. It appeared to work very well but still think it is still hit and miss with the GPS.

 

Will keep playing with GS3 this week to see how it goes as I really want this to track my walks the way my phone does.

First Poster

The problem is, that working concept is completely wrong. Here is an example: I have my phone with bluetooth on, but my phone is deep in my bacpack because I am cycling. So clearly it should work like that: bluetooth on on both, mobile data on on the phone, gps on on watch but off on phone so I can still answer phone without taking it out from my backpack, or stream some music from my phone, or just use data from my phone. Location is different matrter entirely, it should use my watch gps module simply because it is outside and by turning it off on the phone and leaving it on on the watch I have clearly stated what I intended it to do. Well it was a big suprise to me to realize that it does not work this way. Watch is unable to use internal GPS while paired with the phone - why would I buy this watch if I intended to keep my phone out of my pocket? From my point of view - a person who use bike for commuting and wants to use watch for activiy tracking and some occasional call this watch is absolutely useless.

 

So sorry to say this, but you did not solve the problem, you managed to find workaround, unfortunately this workaround cuts of half of S3's functionality.

 

Noiw fight for my money back begins :(

Apprentice

I have the following experiences with GPS on my Gear S3. I've been supported by Samsung very well, and I used, amongst others, this forum and  this post to find out what my problem actually was. I want to share my experiences with others, so that they need not spend so much time on this
issue as I did.

 

My location determination was very erratic. Sometimes it worked, sometimes not, sometimes not well, sometimes not at the beginning of a walk, but then it worked well further under way. It drived me crazy, because I bought the S3 also for keeping track of my activities, and for that you need a good-working GPS.Now I couldn't rely on it.

 

First of all: there are two methods of getting a location for your S3:
     1) WITH a bluetooth connection with your phone, on which location services is switched 'on' and the Samsung Gear S app is opened (in the background is fine), and
     2) WITHOUT a bluetooth connection with your phone, stand-alone. With this, your S3's own GPS-module is needed to determine your location from its contact with GPS-satellites

 

When I started to understand this from the fora (I believe it was this post, actually), I performed several tests, with and without a bluetooth connection with my phone (and on the phone the location services switched on and the Gear S app active).

 

So it turned out when I had my phone with me, option 1), my positon was correct (say, +/- 10m, the GPS resolution) and my walks were registered corrrectly. So no problems with option 1). After my 'training' (walk), the summary also showed my route on a map (at the bottom of the log).

 

(for the bluetooth connection, the 'LE' (low energy) connection with the phone is enough. There's also a 'non-LE' bluetooth connection, but this one is for a larger bandwidth. You can have a telephone conversation with this connection through your S3. This broader-band connection is not necessary for general information exchange like GPS-coordinates or Whatsapp messages.)

 

(During all my testing, when I didn't fully understand how it worked yet, I noticed that the Gear S3 'knows' your general gait-length. With this, it is able to also measure your walking-distance by counting your steps. I recon the S3 needs a good 'learning-period' first with correct GPS-readings, in order to draw conclusions about your gait-length (GPS-measured distance, divided by the number of steps). I seem to remember that in the beginning, I measured wrong distances while walking. It might have been the case that I had no GPS-coordinates (probably no bluetooth connection with the phone and no GPS-reading from the S3 itself) and the S3 didn't have a good avarage gait-length for me yet. It consistently measured a shorter walking-distance that it actually was.)

 

After reading on the fora how the location services worked on the S3, with and without a bluetooth connection with my phone (iPhone 6S, by the way), I started testing option 2). I switched off the bluetooth connection with my phone by switching on the airplane mode (swipe down on the default watch-screen and tap the little airplane) and started a walking-training. For this case to work correctly, the S3 needed to receive the GPS-information on its own. That didn't work at all. Whatever I tried, I didn't get a GPS-reading. It kept 'determining position', without finding it. Often I got the message that location could't be found, please move to an open area' (or something similar), although I was outside, under a clear blue sky.

 

I also downloaded the 'Quick GPS position' app on the S3. An app to show you your latitude and longitue coordinates, and nothing more. With this app, it was clear that a GPS-reading was not possible. It kept saying 'aquiring postion...', but didn't find one.

 

My conclusion was that the GPS-module/function of the Gear S3 must be broken. So then I accepted the fact that I needed to walk the 'Samsung service route'. I called Samsung and after walking the 'support scripts', the conclusion was that the S3 needed a warranty repair. I got a web-link for reporting my faulty S3 and starting a service request. It was all Dutch, so it probably works differently in other countries, but just to show the link:

 

https://samsung.drmobile.nl/sam_nl/device/

 

I reported my S3, the faulty GPS, uploaded my receipt and started to wait for the all free pick-up-and-return-service to happen. From that moment on, I was kept informed perfectly about the status of the transports and repair of my S3. They came to pick it up on a Wednesday evening (small cost for me, but I didn't need to take a day off from work for that). The following Friday, the bell rang on 8:30am. And there it was, my own S3, with a repaired GPS ('board-swap', the receipt said).

 

After several test-walks without a bluetooth connection with my phone, my conclusion is that it works perfectly now. It registers my location, keeps track of my route, everything!

 

I hope I have helped other people by telling my story so that they can skip all the Internet-searching, uncertainties about how it should work and quickly draw the right conclusions about whether the Gear S3 needs a GPS-repair or not.

 

Good luck!

 

Peter

Apprentice

Guys,
I got my S3 two months ago; since then, I have sent it to be repaired by Samsung three times. I've always scheduled collect & repair from the Dutch Company mentioned before. Issue as follows: static, the GPS gets the signal pretty fast and accurately. When running, pace is NEVER-EVER accurate, distance is always wrong and if you pause (like in traffic lights, etc.) GPS can take 1-2 km to pick up signal again, so all your workout spoiled. I have tried everything said here (GPS only, etc.) to no avail. I contacted Samsung via twitter and they advised "to send the device at least 3-4 times so I can get a replacement or refund". Incredible when you buy one of the flagships of the brand!!  By the way, using Endomondo, MapMyRun or Health does NOT change, so it means that the device itself is not working properly.

Update: Just got the message from "Exchange Service NL" saying that they declare my watch as "non reparable" and they will exchange it in the next days for a new one. More to come...
Cheers,

Apprentice

Update: I sent my NEW watch again to the repair service and got it back three days ago: Boardswap (sounds familiar?); tested yesterday and pace is wrong (again) 50% of the time. Run 8.5 Km and recorded 6.5 or so. Running at 4:45'/K it shows 6,7...even 8 '/K. Nothing to do, useless as sportwatch. rest is impeccable.

First Poster

I have had the same problem with the GPS on my Samsung Gear S3 Frontier.

The GSP problem was caused by the Weather app. I went to the Gear S3 app on my iPhone, chose for Apps, Settings per App, Weather, set automatic refresh to every 6 hours and deselected the current location option. The Weather app on the Samsung Gear S3 now showed the message "Add currect location". Went back to the Gear S app on my iPhone and selected current location option again. In the Weather app on the Samsung Gear S3 now the current location was displayed. After that GPS functionality works fine in all the other Gear apps also. Problem seems to be solved. 

Apprentice

Activating the location in the weather app and GPS working fine after that means that your Gear S3 is tethered to your phone. So, it gets its GPS location from your phone and not by itself from its own GPS module. 

 

I guess you should check your Gear's own GPS by putting it on flight mode and then do something that needs GPS. If it then doesn't find a location over and over again (also after rebooting your Gear S3 and even reset to factory settings), your Gear's GPS is broken and you should let it be repaired by Samsung Service. 

Apprentice

Hello,

Thnaks for the suggestion, but unfortunately it doesn't work. I think it has been a mere coincidence that it worked in your case, because if you look at it carefully, the Weather app and others such a Endomondo, Map My Run, etc. have nothing to do. Again, I've been using it extensively for the last 2 months (attention, I am talking about the SECOND WATCH, the one I received as they couldn;t solve the problem before!) and it is still bad when displying pace when running.

Thank you,

Observer

I have the same problem.  Duration kept going, but GPS stops.

Mine was using underarmour Map My Run.

Map My Run support said to delete th app on my phone AND watch.  Turn them on and off, and then reload the software.  I have run with it once now it it worked.    

 

At least the GPS didn't stop.  But it still has problems.  Every time I pause it takes way to long to find me again.  The gps was all over the place.

 

Top Liked Authors