Support

Open search

Galaxy Tab S3 problem with fast charge bugged

First Poster

Hello,

 

I'd like to report the issue I have with Galaxy Tab S3.

When I use my tablet continuously and do the charge with my fast charge adapter, the Tablet will charge in normal mode, the charge acknowledges as a fast charge for a few seconds but it changes back to normal charge. 

 

You will need to reboot the tablet for it to enter a fast charge state again. Otherwise, it won't do a fast charge anymore.

Does anyone have the same problem or how to directly get in contact with Samsung? As this is very annoying that I need to reboot a tablet when I wanted to charge it.

 

Thanks.

10 REPLIES 10
Voyager

I might not be reading your message properly so i'll provide two answers:

1. As far as i was aware the devices that 'fast charge' only fully fast charge whilst the screen is off and the device is not in use. If the device is in use a slower charge rate is used to avoid damaging the battery,

 

2. I have heard previously this sort of problem where the device flicks in and out of fast charge mode when the usb port on the device has dirt inside it / the male connecter has dirt on it.

 

I'm not saying these are the definate answers, just sharing what i've heard in the past.

First Poster

On your point, 

 

1. When the device uses fast charge it will say fast charge in the notification area. It just says adapter plugged in.

2. I tried this with at least 3 cables and check for the cleanliness. However, the symptom appears that it is not due to the cleanliness of the cable or male connector as if I just kept the cable on and do a reboot when booting is done the device detects and goes into fast charge mode again. So I think this might be something on firmware side.

 

New Member

I've been experiencing this problem for over a week. Started with a moisture detected in charging port alert. And ever since fast charging no longer works, it wont even slow charge with a fast charger hooked up, only with a regular charger. Hope they fix this issue soon.

First Poster

I have the same issue. When I use the tablet for a long while (specifically when watching videos) and battery runs down to below 15%, it will not fast charge unless I reboot the device, even though it says fast charging. Once rebooted, fast charge will kick in.

First Poster

I'm also having this issue also when I first plug it in it says fast charging for like a second & then it goes back to normal charging. I have found out that when I turn the device off it will fast charge it just simply refuses to fast charge when the device is powered on! Any help would be greatly appreciated I am guessing I am going to need to send it in unless someone has found a fix for this!

 

Thanks yours truly

Helix

First Poster

I have found a "solution" to this ... push the cable in to charge (like normal) but immediately pull it out and then push it back in. This then fast charges it - well mine does.

Observer

Hello,

did anyone find a solution to this? I tried factory resetting and using a new Samsung charger, to no avail. Also my Windows 10 computer cannot detect the tablet (it could previously). Rebooting and plugging & unplugging the charger don't turn on fast charging, even temporarily.

Had this issue for a several months now, I believe it started after an update. Didn't have any moisture detection messages, the port and the cable are clean. 

I would appreciate @samsung looking into this issue -- would hate ditching my tablet for an ipad pro.

Thanks.

First Poster

Still no update on this issue yet from samsung but there already has been  another software update to the tablet yet it did not address the issue but I have no longer got the moisture detection message anymore but fast charging has never returned but still fast charges when powered off at least. I am wondering if perhaps some one was correct in stating that the tablet can not fast charge because of the power output on the screen is to much on the bevice so technically there is not enough amps to fast charge while the devices screen is in use. To tell the truth the lack of it fast charging has not really messed with my overall usage of the device I simply power it all the way off when I want it to charge quicker and it charges in a ok timely manner. When I plug it up and use it like computer/notebook even when running demanding games like world of tanks that I would assume is pretty demanding graphically on any device considering its basically the PC game counter part just using the old engine as the back-bone before the HD graphics overhaul they did not to long ago.  

 

I just wish Samsung Electronics would give a definite answer to this issue or address it because if it is a power draw issue due to the beautiful screen I can perfectly accept it. Though if a update they provided has caused a software conflict with fast charging feature of the hardware to become in affect useless then I can not, as they should address the issue instead of leaving us not knowing especially if they broke or caused this bug. If anyone does perhaps figure this out please remember this post and let the rest of the samsung community know please!

 

Thanks

Helix (SM T820 with latest update)

New Member

I have the same problem,it start with moisture notfication in usb port which prevent tablet charging except in power-off mode ,then I tried to clear usb cashe and data,after that it charge normally at regullar speed,but some time charge fast  for awhile when pluging in then return to regular speed,help please

Top Liked Authors