Support

Open search

A70 screen will not dim/USB connection.

Apprentice

Hey,

 

I've noticed a problem with my A70 regarding trying to dim the screen when locking manually or expecting it to lock after screen timeout.

 

Basically, my phone won't sleep, at least not whilst charging. I spent a good while playing around with settings on my phone, such as timeout and lock screen settings. I also powered off the device but no luck.

 

After trying to figure out the problem further I discovered that the notification tray is being constantly updated every few seconds swapping between "Android system USB connector connected" and "Android system USB connector disconnected". So presumably this is what is keeping the phone awake as it thinks it is being constantly connected and disconnected from source USB source. I cleaned out the USB port but it was pretty clean to begin with. I'm not getting any notifications regarding any moisture detection.

 

The A70 charges just fine (though sometimes there is a slight delay to it recognising being plugged in) and it seems that the USB tethering interface is working well as I can use the remote debugging feature in Google Chrome (for web development purposes) just fine. As far as I can tell, there are no actual issues with the USB port - it functions as I would expect.

 

The A70 was last updated on the 14th August to "Security Patch level: 1 July 2019" and looking over the log of updates I see that "The charger/USB port's moisture detection algorithm has been improved" - so someone somewhere has been looking at this feature and I doubt it coincidence that my device has just developed a fault, given that I've not had it anywhere near moisture or excessive dirt.. and the port still actually works!

 

I've also tried Safe Mode but the issue persists. Also, if I power the device off, then plug it into the wall, power it on, the notification issue stops... until I unplug it/switch off the wall socket - then it comes back again.

 

Anyone else having similar problems?

334 REPLIES 334
Explorer

Mine is doing exactly this as well. I have cleaned the usb port and no change.

If the recent update is causing a problem, is there a way of rolling it back?

New Member
Yes same issue and I thought that my USB socket had an issue I cleaned it but still the screen won't go dark
So I changed the notification so that whenever the cable is connected or disconnected the screen stays off but it's a drag to see the notification
Explorer

@SlayerEGX wrote:
Yes same issue and I thought that my USB socket had an issue I cleaned it but still the screen won't go dark
So I changed the notification so that whenever the cable is connected or disconnected the screen stays off but it's a drag to see the notification

Hi, can you describe how to change the notification for cable connect? I have looked but cannot find it.

thanks in advance

b-c

Apprentice

So I got mine fixed this afternoon at my local Samsung store (fortunately 5 minute walk from my work!)

 

They ran a diagnostic check which flagged no hardware issues but did flag an issue with the latest software update. Something went wrong during install (maybe some buggy code/connection from the update servers?) and the best fix they said was to flash the update on the phone again. I've got it back now and it's factory reset but with the latest update applied. Problem seems to have gone away!

 

A factory reset might be your best bet unless you can get to a Samsung store who can do something a bit more sophisticated. Hope you all get yours fixed.

Apprentice

So I thought it was fixed but the issue came back this morning despite the 'solution' I posted yesterday.

 

How do we let Samsung know about this and get it actually fixed?

Apprentice

i have the same problem and this came with the latest software update..

i hope samsung finds a solution.

Apprentice

Turns out that my sub board was bust so I had a new one fitted in the end. Just got it back today, hope this is the last of it.

First Poster

I have the exact same problem.I had to turn off my phone because it was wasting my battery .Honestly,I don't know what to do.It is really annoying.Can someone please tell me how to fix it and what to do?

First Poster
Can you tell me where did you find that option? I need it asap... thank you friend
Top Liked Authors