Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Gear S2 no longer automatically connects since update

(Topic created on: 24-07-2019 07:52 PM)
AC41
First Poster
Options
Wearables

Since a Gear Wear update on my S8, my Gear S2 no longer automatically reconnects to the phone when in range. I have to manually open the app and click connect. This was never necessary before and is quite annoying. I've been through all the settings and also tried clearing the Bluetooth cache but to no effect. Any ideas? 

4 REPLIES 4
strawberry cake
Hotshot
Options
Wearables

Hello!

 

 

- please ensure that Bluetooth connection is within range (10m)
-No obstacles such as walls or electrical equipment
-Restart your smart watch, press the Power button once and then tap Restart
-Clear cache of Wearables app, go to Settings > Apps >  Wearables app
-Clear data of Wearables app, go to Settings > Apps >  Wearables app
-see if Wearables app has the latest version, you may check this on Google Play or Galaxy Store
-Check for any software updates for your smartwatch, go to Menu Settings > Info > Update (if there's one)

 

If persist,
Backup the data on your watch and have it factory reset, Menu Settings > Info > Factory Reset.

 

If persists, see an engineer at your nearest support centre for checking and fix.

 

Thanks ^_^ 


 (\_/)
(='.'=)
(")_(") strawberry cake so delicious

0 Likes
tangocharlysier
First Poster
Options
Wearables

That's a chatbot reply, isn't it? 

Having a similar issue: Gear S2 is recognized by app but the app stopps at that stage and doesn't connect. 

Cleared cach, data and even reinstalled app, reset S2 twice. No success... 

0 Likes
LuisTA
First Poster
Options
Wearables

Hi! have manage to solve it?

Im having the same issue

0 Likes
tangocharlysier
First Poster
Options
Wearables

Yes, it was an easy fix. 

 

I purchased a Huawei Watch GT 2 and it works like a charm and for 2 weeks without charging. 

0 Likes