What are you looking for?

Showing results for 
Search instead for 
Did you mean: 

Original topic:

Classic S3 suddenly not pairing with phone (OnePlus 5t, Android 8.1.0)

(Topic created on: 23-10-2018 11:22 PM)
First Poster

I've had this problem since updating to the "Galaxy Wearable" app (~2 months or so).  My watch lost the ability to connect to my phone via bt.  So, I did a factory reset on the watch, cleared the data on all watch-related apps on my phone, and did a full un-/re-install of the watch apps.


Now, when I run the Galaxy Wearable app, my watch model isn't listed on the "Pick your device" screen, so I select ""Mine's not here."  It will detect my watch, but I can't select it because the button will first appear in orange/yellow but is immediately greyed out and can't be selected.


When I go into Bluetooth settings on my phone, the watch will be listed as an available device, but again, I can't select it and the phone will not pair with it.  I've tried just about everything I can think of and a few things that I've read online, and nothing seems to work.  Please help!


Phone: OnePlus 5t (A5010), Android 8.1.0, T-Mobile.

Watch: Samsung Gear S3 Classic, received as a Xmas 2017 gift.