Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Tab s8 ultra fault

(Topic created on: 29-01-2023 03:07 PM)
1033 Views
Members_3Q3loWV
First Poster
Options
I had previously enjoyed a very smooth, non-laggy, ultra low latency with 120Hz output display connection from my Galaxy Tab S8 Ultra to my Samsung Neo QLED QE50QN90BATXXU TV, via a certified HDMI 2.1 cable connection using a USB-C to HDMI 2.1 dongle which has full 144Hz compatability at 4K compatability (had to hunt around for that special dongle).
 
Just to note, when I connect to the external display I simply use the default mirroring and I choose not to enable DEX. DEX itself is no doubt useful for certain situations, however I just had chosen to stick with basic mirroring through the HDMI 2.1 link as this diverts all GPU power to concentrate on driving only one display output (which is merely mirrored) and not having the GPU drawing graphics for two different outputs. Helpful for emulation of games.
 
Initially this was all good, because I was able to set my Samsung QN90B TV onto Game Mode with everything connected up properly and I enjoyed having extremely low almost non-existant latency in Game Mode and better still the experience was very good because I was getting 120Hz performance on the outputted display connection - fantastic! (though the TV can display up to 144Hz, however the Tab S8 Ultra's capability is a very respectful and still impressive 120Hz to the TV which looks great)... well it did look great when it had worked previously.
 
However, I did have a bit of a break and had not connected the Tab S8 Ultra to the TV for a period of time. Meanwhile during this period of time I had done a number of Samsung/Android System Updates (at least 3 separate updates over time), but then the problem with the connection to the TV happened.
 
Connecting to the external TV display is now a completely unpleasant affair. It's laggy and stuttery. The TV in Game Mode only reports a nauseous 30 fps (30Hz) and the latency is absolutely terrible and super delayed. Even the Tab S8 Ultra's own display is stuttery and laggy as well as the external display's.
 
I'm left feeling that I wished I had never updated the S8 Ultra. There appears to be no menu and no proper settings or means to adjust anything when connecting to external display via USB C to HDMI 2.1, something admittedly which I didn't have to do before because it all just worked properly back then.
 
Samsung need to fix this a.s.a.p. as the cable link is the only way to obtain virtually no latency and the S8 Ultra's 120Hz to the QN90B's external display. Just to reiterate this problem did not exist before.
0 Likes
4 REPLIES 4
-Robot-
Samsung Members Star ★
Options
If you want assistance you need to contact support, you can do that via members app
0 Likes
totteraptor
First Poster
Options

I have a similar experience. My previous Samsung Galaxy Tab S7+ is running Android Version 13 and One UI version 5.1.1. and is able to drive my 32 inch monitor without noticable lag using an original Samsung USB-c to HDMI cable . My new Samsung Ultra S8 is running Android 14 with One UI  version 6 is having a noticeable lag on both the monitor screen and its own screen (when connected). 

Interestingly, the S7+ will turn off its own display after a while when connected to external monitor. The Ultra S8 keeps it on. Not sure if that is important info. 

Anyway, my expensive new and supposedly ultra fast tablet is completely useless with an external display. 

If anyone knows what might fix this I'd love to hear it and is seems that many other members might benefit as well. 

0 Likes
il0vera1n
First Poster
Options

Do you have any Updates on this? I have a Brand New Tab S9 and gaming via hdmi on my LG C1 is impossible with this lag...

0 Likes
totteraptor
First Poster
Options

Hi again, 

I found a solution to the problem that I described. It turns out that Samsung have created a new version of Samsung Dex which has a different user interface. In the Settings it is possible to select to use the old Samsung Dex and that solved the problem with sluggish external monitor. Go to "Settings" => "Connected Devices" => "Samsung Dex" and select "Classic" instead of "New". I also have it set up to use screen separately instead of mirroring but have not experimented with whether that makes a difference. 

Let us know how this works if you try it out.....

0 Likes