Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Smartthings failing to connect to Honeywell THR99C3110 thermostat

(Topic created on: 16-02-2021 10:48 AM)
1492 Views
ChrisRlB
First Poster
Options

I have a Smartthings hub V3, purchased from Aeotec UK. I also have a Honeywell THR99C3110 thermostat, which my Smartthings hub tells me is supported (it is listed in device compatibility), and Samsung advertise as being compatible. However, when I try to add the thermostat to my hub I get an error message after I have entered my Honeywell Home credentials that says my credentials have not been recognised.

The credentials are valid and I can login to my Honeywell Home account online and the thermostat with these credentials, so I know they are correct. I have factory reset both devices, re-entered data and the error remains. My software version on the V3 hub is 1.7.60.23.

I have tried deleting the cache and data in the app (Android - tried on two different devices), but nothing works.

Any suggestions and help would be appreciated.

0 Likes
1 REPLY 1
Members_ccJJs8x
First Poster
Options

Exactly the same issue here… What i’ve identified is that the honeywell app which smartthings wants you to log into is different from the TCC app on which the device we bought is regestered, and its not compatible with the honeywell home app. The american version of the honeywell home app has an option to import the TCC devices but the UK version does not. I tried a few things to get around it but have gotten nowhere. Did you manage to find a soloution?

0 Likes