Support

Open search

Ring Door Bell App

Highlighted
Apprentice

I am using the Ring Doorbell app. It has worked perfectly on my S10 plus. Since the change to the Beta Android 10 - if I try to use Live View of my doorbell the app totaly locks up. I have spoken with the Ring Company they have checked my doorbell and all is working correctly. Live View works on my desktop Ring app and also on my Samsung S7 running Android 9. 

 

Any thoughts

 

Td

11 REPLIES 11
Highlighted
Helping Hand

Hi @TdIbz,

 

Have you tried clearing the cache on the app or uninstalling then re-install

On my S10+ powered by Android 10 improved by One UI 2.0,
Ben Ginders
Highlighted
Beta Moderator
Beta Moderator

Hey @TdIbz 

 

Unfortunately some 3rd party apps may expeirence issues with the Beta software as they are not optimized for it yet.

Send an error report using Beta Feedback option in Samsung Members. 
If there is a fault on our end, then our developers will be sure to fix it!

 

But if it depends on the app developer, then it might happen that it will work only once the Beta ends and the app is updated.

Highlighted

Hi, thanks yes I have cleared the cache, unistalled reinstalled ans it is just the same.  I think its a problem with the app and Android 10. Thanks anyway Td

Highlighted
Hi, I have sent an error report lets hope it shows something. Thanks Td
Highlighted

Same problem with mine, live view on cameras and door bell just locks up

Highlighted
Any news on this. I am using the latest version of the Beta and The Ring Doorbell Live View is still not working. Anyone having the same issue or have a solution. Thanks T
Highlighted

Hi mate

 

I have a samsung S10 plus and my ring door app works fine. I've got a ring door bell pro and the flood light camera and both work fine.

Highlighted

Hi, thanks for your reply thats curious. Just to be specific - the app in all areas except for Live View of the camera works fine. It is only when I try to remotely connect to Live View thst the app crashes. 

Remote Live View from my PC using the Windows Ring App works fine as it did on my mobile prior the upgrade to Android 10.

 

Thanks for your input in any case.

Regards T

Highlighted

I have the same issue. I reverted back to stock and it worked fine. Forgot to unenroll from beta so it forced an update again so will revert back until it works with critical apps.