Open search

S8 smart lock - trusted location issue




the smart lock - trusted location option is not working as it should do.

i've set up my home address as a trusted location, however, my S8 device is unlocked everywhere.

just realised this while i was in the office, that i can access my device withouth using the PIN or the fingerprint.

i've oppend the maps and the location that it shows up is correct. 2miles away from my home address.


the only workaround that i found was to turn off the trusted location, and now the device is asking for the PIN.


this is a serious security issue. the trusted location option is not that trusted :smiling-face:


any idea?




116 REPLIES 116

Yes, I have it on high accuracy all the time, but I live in an old building with castle thick walls and in ground floor. There is no way satellite positioning works here. Google Map services uses wifi signal and net node points to "guess" the phone location, and depending on the star positions in the universe, decides that my phone jumps by itself back and forth in the courtyard, usually in some corners opposite the corner where my home is ; )


My smart lock is still working.

I think this is the solution for most people besides the guy with the accuracy problem. 

Recap: go into settings/cloud&apps/samsung acc/places then add your home.

My smart lock is open at home since i did this. Before it would not stay ipen at home 



No luck with that for me either, still unlocking everytime I'm home unless I use trusted devices, I've taken google maps and location services off the battery saving *****, and turned off the battery saver, still get drift

Did you check time to time your exact location. If the dot jumps around even a little (in my case 20m around the court yard), I know for sure that it will not help what ever one registeres as home. As said, I did register my home address and it did not help at all, because phone thinks that I am outside ; )
Check three days in a row at different times closely in Google Maps (zoom in as much as you are able) where phone locates you, and if the dot jumps around tens of meters and this registering your home address to Samsung eliminates the fact that position changes radically, then I believe you. 😃

Ok mine stuffed up again after 3 days but i got ut working again by deleting my home amd trustes places on all accounts then addes my home again, didnt work but then I added the trusted place as my homes co-ordinates and ut is working again. Hope this is helping someone and i hope this lasts. Wtf is wronf with this, samsung needs to fux this bug in an update asap.



They do but problem is this is a 2 month old post now and they haven't done anything, and it got marked as solved, luckily my upgrade date is coming soon and it will not he another samsung


AGREED -  Although I am not who sure to pin this issue on, it sucks. The S8 always seems to be a complete hasle to unlock. Add Bixby (and the Bixby button) , and I absolutly hate this device.  Cant say I ever felt that way about any phone.


I even found a "how-to (s8)" video on-line, and the guy fumbles with the phone through 4 key presses and a couple of swipes before he gets it unlocked.  The S8 is my last Samsung phone.  I had an S9 reserved, but decided I don't want another year hating my phone.  Will probabaly try the LG..  (Although I hear it will have a dedicated assisant button - That I am sure will suck.)  I may even get a cheapo for a year until they get fingerprint on the glass.  When I broke my S7, I had a $40 phone off Amazon, and it worked fine.  I have been tempted to put my SIM back in that and wait out a phone I might actually love  😕


Contract with Amazon, drop an Alexa Button, I am all in.   


I was having the same issue: just wanted to be able to swipe to unlock my Note 8 at home instead of having to use my fingerprint. I followed some of the steps other repliers provided and it was all too much and/or didn't work. 


I was able to resolve my issue by adding my address by Google coordinates (typing in my address didn't work). I hope it works for you too. 


*side note - I restarted my phone 1st (just in case) and I did not delete my "Home" that I already had saved in Google maps. It now just shows 2 trusted sites for the same location although only the one with coordinates works for this ☺


So here's how: 

○ Go to settings 

○ Select "Lock screen and security"

○ Select "Smart Lock"

○ Enter your password

○ Select "Trusted places"

○ Select "+ trusted place"

○ Find the site you want on the map

○ Move the map until your marker is over the correct site

○ Select "choose this location" at the bottom

○ A box will pop up that says "Use this location? " with your site's coordinates and a small map showing your selected site

○ Choose "Select" from the bottom right corner


After you come out of settings, try turning your screen off, waiting about 10 seconds, then l light the screen back up and swipe. Voila!


Set it that way before, I'd go to add trusted location, click the bottom in the bottom right to center on me and add so it shows home and basically a second home with coords but never fixed it for me, even went hack to the beginning of the thread and tried the post labeled solved, clear cache, still unlocking everytime


I've done everything to fix Smart Lock. Stop wasting time trying to fix this bug with internet tutorials. This is an Android bug. The problem occurs with any manufacturer's smartphone. What happens is that after 4 hours of inactivity, the Smartphone asks for the credentials again (OK, that's how Smart Lock works). The bug is: after entering the credentials (after 4 hours of inactivity) the smatphone does not understand that you have disabled it and that it is time to know that it is in a trusted place. Clear cache or even reset your smartphone to the factory default will not fix the bug because the next time it goes into inactivity after 4 hours, the problem will return.

Top Liked Authors