Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

Read this before upgrading from Marsmallow to Nougat (A6 to A7)

(Topic created on: 01-04-2017 02:26 PM)
Dunstan
Apprentice
Options
Other Smartphones

Hi everyone, I'm using a Galaxy S7 with Vodafone and think it is a brilliant phone, but... I've just upgraded from Marshmallow to Nougat (Android v6 to Android v7) and while there are some things to like there is one massive drawback for me.

 

It is now apparent that the Vodafone wifi calling feature (ability to make a call over wifi when there is no signal) is NOT SUPPORTED by Nougat. This is very frustrating as I live in a poor signal area and it is a facility I used a lot with my phone. When I called the Samsung help line to see what could be done they were clearly aware that this was a feature in v6 that is no longer supported in v7, but could not offer anything more useful than an apology.

 

Style wise Nougat is cleaner than Marshmallow, although not all users will like the smaller default font. The native email app continues to be very good especially at handling multiple email accounts, which is not something many of the specialist email app providers do all that well. At first I thought the phone app was worse with favourites missing, but now I've figured out the new arrangement, it is actually easier to use. Notifications are not as readable in Nougat (I much preferred the little space between notifications in Marshmallow) which is a very basic error for a facility that is used so much by everyone

 

In the settings menu I preferred the Marshmallow layout where you could place a range of frequently used settings at the top of the list. Now you have to dig around for ages to find them, although the search bar at the top can help with this. You will search in vain for the old 'Phone' app though, because it doesn't exist any more (and this is where the wifi calling feature was located).

 

Overall, if it was easy to downgrade back to Marshmallow then I would do it. If the wifi calling feature is not fixed very soon then I will be forced to find another solution which might even be as radical as an iPhone. This is a a real shame because, as I said at the start, the Galaxy S7 is a brilliant phone.

 

How Samsung can ignore support for a core feature is quite beyond me. This may not be an issue for many users, but I am one very unhappy S7 owner right now.

 

David

0 Likes

1 Solution


Accepted Solutions
Solution
Dunstan
Apprentice
Options
Other Smartphones

Problem Solved.

 

Just by chance this morning I found the menu option in Nougat to enable wifi calling.

 

Open the phone app

Click on the three dots in top right corner

Select 'settings'

Scroll dow and select 'more settings'

Here you should find a 'wifi calling' on-off switch

 

Now i have done that, my wifi calling switch appears at the bottom of the 'settings' menu and not in 'more settings'.

 

It looks like the option was in Nougat after all, so apologies to Samsung for suggesting otherwise. It is strange that the Samsung help desk seemed to think my problem was a known issue and they were not able to point me to the right solution, but hey-ho.  I'm happy again now.

View solution in context

5 REPLIES 5
BandOfBrothers1
Pathfinder
Options
Other Smartphones

Hi David,

 

 

Was the phone supplied directly by Vodafone U.K or was it acquired through a 3rd party ?

 

 

My Current Phone > Samsung Galaxy s7 edge SM-G935F. {XEU}
0 Likes
Dunstan
Apprentice
Options
Other Smartphones

@BandOfBrothers wrote:

Hi David,

 

 

Was the phone supplied directly by Vodafone U.K or was it acquired through a 3rd party ?

 

 


The phone was supplied by Vodafone and the wifi calling feature was enabled through Vodafone. 

0 Likes
BandOfBrothers1
Pathfinder
Options
Other Smartphones

Ok.

 

There has been some posts on the Vodafone U.K. Forum concerning this. 

 

Some have found that turning off Calling Over Wifi in their online myvodafone for 24 hours and then reapplying has helped. 

My Current Phone > Samsung Galaxy s7 edge SM-G935F. {XEU}
0 Likes
Dunstan
Apprentice
Options
Other Smartphones
Thanks for taking the time to reply to this and i will look into that solution, however I mentioned previously that I have spoken to Samsung and the basic issue is the feature (which can be enabled or disabled in the settings of Marshmallow) simply does not exist in Nougat.
0 Likes
Solution
Dunstan
Apprentice
Options
Other Smartphones

Problem Solved.

 

Just by chance this morning I found the menu option in Nougat to enable wifi calling.

 

Open the phone app

Click on the three dots in top right corner

Select 'settings'

Scroll dow and select 'more settings'

Here you should find a 'wifi calling' on-off switch

 

Now i have done that, my wifi calling switch appears at the bottom of the 'settings' menu and not in 'more settings'.

 

It looks like the option was in Nougat after all, so apologies to Samsung for suggesting otherwise. It is strange that the Samsung help desk seemed to think my problem was a known issue and they were not able to point me to the right solution, but hey-ho.  I'm happy again now.

View solution in context