Open search

Disabling automatic connection to open WiFi networks on Galaxy S7


If I leave WiFi enabled outside of home/office then my S7 rather annoyingly automatically tries to connect to any open WiFi networks.  I know from using other Android devices that usually there is an option to disable this automatic connection behaviour, but that option appears to not be there on the S7 (6.0.1).  I'm slightly surprised at this omission given its something of a security risk as well as a nuisance (especially when it automatically connects to a network which then redirects you to some login page).  


Assuming i'm not missing something, can such an option be provided/put back?  Can anyone in the Nougat beta clarify whether such an option exists in that?


Hey, thanks for posting! 


Has your phone been connected to these open networks at any point? If so, tap and hold on the open network and press 'Forget Network' option. 


Be sure to let us know how you get on! :manhappy:

As its an open network then 'forget' isn't presented as an option. Also I don't want it to automatically connect to open networks in the first place. This is a pretty standard option and i'm astounded that its not available.

Can you head to Settings > Data Usage > More > Restrict Networks. Tap on the networks you'd like to automatically connect to in the future, all the other's will be disregarded. 



Someone elsewhere suggested this to me elsewhere a few days ago. The information on that particular screen suggests that it only applies to background processes and appears to be more for bandwidth limiting than for outright blocking. And having tried it I can state that it does not work in the fashion you suggest (i.e. it still automatically picks up an open network that I had deselected in this screen).

And once again, I would prefer to have the choice not to have connected to an open network in the first place rather than blacklist one after the event (which is what this option would do if it did what you think it does).
New Member

I have the same issue. On default Android there is an option if connecting automatically to open WIFI is enabled.

Really hate this behaviour and my S7 to. For energy consumpion and securuity this is really bad.  


After browsing through countless forums I finally get to the answer. My mobile kept connecting to my neighbour's open network and I couldn't find the way to make my mobile ignore it. Works perfectly for Android 6.0.1. Thanks EmmaS.


Hi, I'm a S8 user, currently running offical ROM with Android 8.


From what I found I got 3 suggestions:

  1.  Disable option to disable automatic connection on open WiFi - PERFECT SOLUTION, but not available on my Android 😞
  2. Forget open networks - COULD WORK, but...  make not much sense to have this individual step on each networks
  3. Select network as restricted - DON'T KNOW IF WORKS, as far as I understand, only blocks background usage.

Am I missing any other option?


EmmaS  answer is WRONG. As the option "restrict network" is under "data usage" it has a different meaning: A restricted wifi network is supposed to have a LIMITED DATA PLAN. Your phone will still auto-connect to this wifi network, but it will behave as being connected to a mobile network.


At the time of writing (2019-06-30) my recently updated Samsung Galaxy S7 DOES NOT auto-connect to UNKNOWN open wifi-networks! If you have connected to an open wifi once, it WILL AUTO-CONNECT to this network from this point on. Unless you tap "forget" on this network. To stay secure, don't use open networks. But if you did, don't forget to "forget" it 😉

Top Liked Authors