Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Mobile data not working after disconnection from WiFi

(Topic created on: 26/02/19 16:39)
xxmicrocutsxx
Apprentice
Options
Galaxy S9 Series

This fault occurred after the most recent update of my S9. When my phone disconnects from a WiFi network (whether manually or once out of range) my phone will display either a 4g or H+ but no data is sent or received and apps/browser will confirm the phone is offline. The only way I can get mobile data to work again is to either toggle it off and on or go into flight mode for a short time.

This happens on any WiFi network (home, work, public) and I have the auto WiFi switcher features tuned off. Has anyone else come across this issue? I reset my network settings but that hasn't helped. Would prefer not to have to factory reset to correct a fault which Samsung seem to have introduced themselves. 

Thanks

53 REPLIES 53
Pahogg
First Poster
Options
Galaxy S9 Series

Good luck there as did that and spent two hours with support online and getting it back up and lost some stuff and it did nothing to solve the problem... Did you finally get it fixed as mine still not working...

0 Likes
Reply
Beaner
First Poster
Options
Galaxy S9 Series

Nope. Although it isn't happening as frequently, it will suddenly and inexplicably not send or receive texts or calls. I've done their fix-all factory reset which made absolutely NO SENSE since it happened right out of the box. SMH. I'd be better off taking a hammer to the screen and getting the store's service plan coverage for a new phone.

0 Likes
Reply
Pahogg
First Poster
Options
Galaxy S9 Series

Sorry about that as I  agree to taking a hammer to the screen as Samsung has a problem they are not dealing with and their support online and by phone is worthless. Spent over two hours yesterday with a full factory reset which was annoying and didn't work. Certainly won't buy another Samsung product as thought they were better than this as this problem goes back a long way and still not dealt with. 

0 Likes
Reply
rakitin
Apprentice
Options
Galaxy S9 Series

Phone unable to connect to 4g after leaving wifi started happening to me after the latest update (25th of March). Definitely never buying a Samsung again .

0 Likes
Reply
AlexYG
First Poster
Options
Galaxy S9 Series

Samsung Note 8. I have the same problem. Hard factory reset helped.

0 Likes
Reply
denman86
First Poster
Options
Galaxy S9 Series

yes same issue on THREE UK network. Seems some people who reset default APN settings got it fixed but didnt work for me. 

3G works fine

Only issue is 4G

I disabled VoLTE and this worked for me, but obviously I want to be able to use VoLTE!

Have spoken to Three and Samsung and both blame eachother

 

We all need to make them both aware of the issue so they provide a fix in next software update

0 Likes
Reply
ChrisW
Explorer
Options
Galaxy S9 Series

I've also started to experience this problem (I have the dual SIM variant but only use it with one SIM and an SD card). Like others, I've found that either disabling VoLTE Calls - or toggling Flight Mode on and off when switching between WiFi and 3G/4G - restores my cellular data connectivity.

 

However this is not a solution, the phone did not do this out of the box. I'm pretty hacked off that I have to disable VoLTE Calls which is a useful feature for me.

 

Enabling/disabling Wifi Calling makes no difference. However if I have VoLTE Calls enabled while connected to a wifi network, if I disconnect, immediately I have no cellular data. It magically starts working the moment I disable VoLTE Calls in the Settings -> Connections -> Mobile Networks menu.

 

My phone was given a full ADB diagnostic by the Samsung engineers at a local service centre last week and nothing untoward was indicated by the tests. This appears to be a new bug introduced by the most recent OTA update.

SammyHawk
Explorer
Options
Galaxy S9 Series

Latest patch works for me... VOLTE is back 

ChrisW
Explorer
Options
Galaxy S9 Series

Unfortunately VoLTE still isn't working on my dual SIM variant. Only using a SIM in slot 1.

 

Screenshot of my current patch, at least until I checked just now:

 

Screenshot_20180810-212443_Software update.jpg

 

I just did a manual check for software update and it's currently downloading an update! Why it didn't download it automatically I don't know...

 

Screenshot_20180810-223832_Software update.jpg

 

Is this the patch your device is running? 

0 Likes
Reply
Gumpy321
Explorer
Options
Galaxy S9 Series

August patch is the latest and fixed the problem for me.

ChrisW
Explorer
Options
Galaxy S9 Series

Yep, initial tests look good here too - data works after disabling wifi with VoLTE enabled. The data connections to the Three VoLTE endpoints don't get stuck in established state (everything reconnects properly) and calls over 4G work, happy days. Hopefully it'll continue working 🙂 thanks for pointing out the software update! 

0 Likes
Reply
ChrisM
Moderator
Moderator
Options
Galaxy S9 Series

Hi all. Is everything still working OK for everyone after the latest update?

0 Likes
Reply
SammyHawk
Explorer
Options
Galaxy S9 Series

So far so good. Not noticing anything worrying at the moment.

 

Had a slightly hairy moment when I had no signal on both my Sims at the same time when looking to pay using an app at the meter - but it may have been nothing other than a coincidence 

0 Likes
Reply
ChrisM
Moderator
Moderator
Options
Galaxy S9 Series

Good news, @SammyHawk! Thanks for the feedback!

0 Likes
Reply
cpoll
New Member
Options
Galaxy S9 Series

Where do I find VoLTE enabled? Also, I have found the data service is disconnected, would that be similar?

0 Likes
Reply
Stevemyland
First Poster
Options
Galaxy S9 Series

Hi. I'm not sure where you enable VoLTE. I believe this is only available if you have EE as your service provider. If that is the case you will need to pop into a shop as I'm vodafone.

My data service was not working either and I tried a reset and it's worked perfectly since. I'd give that ago. 

 


 

0 Likes
Reply
ChrisW
Explorer
Options
Galaxy S9 Series

Depending on whether you have a SIM free or carrier-locked model, the VoLTE setting may not be available. On my SIM free device, it's in Settings -> Connections -> Mobile Networks and is the option called "VoLTE Calls". When enabled, you should see your phone stay on 4G when calling, instead of drop back to 3G.

0 Likes
Reply
TroyT1975
New Member
Options
Galaxy S9 Series

Just got updated to Android V9 on my Galaxy S9 and this problem got introduced, after VoLTE had been working flawlessly on the previous version.  Had to turn off VoLTE or no Mobile Data at all, update on my phone was approximately Feb 1, 2019.

0 Likes
Reply
butt0nfreak
Apprentice
Options
Galaxy S9 Series

I have the same problem with my Samsung Galaxy A8 Dual SIM 2018 (SM-A530F). Used in the Netherlands with local carriers.

 

I bought the phone a week ago and it came with Android Oreo patched with the july 2018 patch out of the box. I had this problem since the unboxing.

Gonna try the fix I found on https://eu.community.samsung.com/t5/Galaxy-S9-S9/Can-t-switch-from-Wifi-to-Mobile-data-automatically... and see if it helps.

For me however the settings are not under the dialpad settings. For me they are under:

Setttings --> Connections --> Mobile Networks --> VoLTE calls <sim card name> 

I have disabled the option from there. Hope this helps other users.

0 Likes
Reply
butt0nfreak
Apprentice
Options
Galaxy S9 Series

Okay, just a quick update...

 

So for my Samsung A8 2018, the fix with disabling VoLTE did not work.

 

I did find that the APN settings were incorrect...once I corrected them withe the settings the provider specified and a quick restart after that to apply the new settings everything worked correctly again :smiling-face:

ChrisM
Moderator
Moderator
Options
Galaxy S9 Series

Great to hear @butt0nfreak. Thanks for the update!

0 Likes
Reply