Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Disable auto connecting to WiFi?!

(Topic created on: 28-11-2018 03:02 AM)
zippedcube
Apprentice
Options
Galaxy S9 Series

I love my S9+ but it has a problem where it constantly auto connects to WiFi hot spots. I'll be writing a message or checking an app and I get interrupted by the screen "Sign-in to use this network...". This is extremely annoying as it happens all the time and even if I click "disconnect for this network" or "dismiss" it comes back a few minutes later. This happens for every free public WiFi I've used in the past when it's detected, but when I don't want to use it like when I'm walking passed a restaurant or a bus with free WiFi.

If you see the attached screenshot of my advanced WiFi settings, you'll see the "Turn on Wi-Fi automatically" is disabled - this setting makes no difference. I usually turn WiFi off completely, then get home and forget to turn it back on and use all my data. I also had this problem on my previous S7 edge for the whole 2 years I had it. Any idea how to fix it?

 

tempFileForShare_20181128-024150.jpg

0 Likes
3 REPLIES 3
BandOfBrothers
Samsung Maker ★★
Options
Galaxy S9 Series

I have a similar issue with my Note 9. 

 

My mobile network offers wifi hotspots and because that's integrated into my sim card then if my wifi is turned On it will try to connect even with Wifi direct also Off. 

 

I cannot dismiss / forget them. 

 

Really if you've chosen to forget or dismiss a wifi connection then that should be that in my opinion but the manufacturers and networks want connections to be seamless where a person can just let a phone do its thing which I submit is what most want until they reach a bug like this. 

 

Sadly I had no alternative but just to turn Wifi Off and manually turn it back On when needed via the pull down shade at the top of your phones screen. 

 

You may need to do the same. 

 

 


Daily Driver > Samsung Galaxy s²² Ultra 256Gb in Phantom Black.

The advice I offer is my own and does not represent Samsung’s position.
I'm here to help.

0 Likes
daveparnell
Student
Options
Galaxy S9 Series

Long press on the network name and you'll get a pop up menu, select "Manage Network Settings" and untick "Auto reconnect" - that should do it .

0 Likes
zippedcube
Apprentice
Options
Galaxy S9 Series
Amazing thank you! I wish there was just one button that did this but this will do the job :smiling-face: