!-- End Google Optimize -->
Support

Open search

Unable to connect screen mirroring/smart view s9+

Highlighted
First Poster

I have just upgraded to the s9+ and the device no longer detects my Samsung Tv's but does the Chromecast devices I have in the Smart View application.

 

I used to be able to play movies without screen sharing giving me the ability to still be able to use my device whilst the content was playing.

 

Unfortunately the settings within smart share are limited and I have gone through the settings on my Tv's to ensure they are permitted but the phone just will not pick them up.

I have been casting to my screens since the all share days which worked perfectly fine.

Any ideas what could be stopping my device from working in this way again?

46 REPLIES 46
Highlighted

I'm surprised a flagship "premium" device from a large company like Samsung can have a bug like this after such a long time of it bring reported.

 

This never happened on my s7 on the same screen mirroring devices so it's a fault of the s9. 

 

Disappointed.

Highlighted

With the new update try doing the following

Open Smart Things > choose your TV > then hit the menu button ( the three dots) and finally select mirror screen ( smart view). 

Hope this helps you guys out 👍

 

 

Highlighted

 Juarez10, those are definitely the right steps. I am adding this because mine wouldn't work until I did a few other things. Now, it works just as you described. 

 

I was able to finally fix my connection to my smart TV. Before I did the following steps, my connection was horrible IF I got it to connect at all.  I do a lot of work outdoors and I have an outdoor Wi-Fi extender. I like to mirror my phone to the TV sometimes, but I often mirror the TV  to the phone when I'm outside. No matter what I did with my new S9+, I couldn't get any of it to work. When I went to Smart Things, my TV was there and most of the time I had the mirroring options. It just wouldn't connect when I clicked them.

 

This is what finally worked, but I am admitting to you that I dont know which of these steps were actually necessary. Each time that I attempted one of these connections, I received permission requests between the two devices. I personally think that steps 1, 2, 3, 5, 7 and 8 are what did it, but wanted to list everything I did. Just before I started these steps, I had also opened up smart view just to see what would happen. The phone didn't even see the TV. Both of my devices were on the same Wifi connection so I didn't understand why they didn't see each other.  So then......

 

1. I went to Settings, Connections, Wifi and hit the Wifi Direct option. It began to search for devices.

2. I went to the TV and selected Menu, Network and again I selected Wifi Direct. This time, both devices found each other, BUT.... If I tried connecting to the phone by selecting it on the TV, it wouldn't work.

3. I selected the TV from the phone and this time a different permission request popped up on the TV. It said they were connected via Wifi Direct. Ok... great. I'm connected. Now what?

4. I went back to Smart Things hoping it was solved, but found that the only option that I had was sending media (pics, videos and music) from the phone to the TV.

5. I opened up Smart View again, on the phone and this time I saw the TV. When I clicked to open it, I got another request to allow connection on the TV. I allowed it and it connected, but I again only had the option to send media from the phone to the TV.  No mirroring.

6. I went back to Smart Things on the phone and the TV still showed up as being connected, but it said "Smart View" beside it. Still couldn't mirror at all. No mirroring options listed.

7. On the phone, I went back to Settings, Connections, Wifi and the Wifi Direct. My TV was listed in the Wifi Direct list and it said "click to disconnect" 

8. I clicked on it and it disconnected. I was stumped and really angry at this point.

9. I went back to Smart Things and once again selected my TV just to see what would happen. The mirroring options were back, but I didn't have much hope that it would actually work.

10. I clicked on the option to view TV on phone. It worked with no problem. I disconnected and then mirrored the phone to the TV. Yep. It worked. Success! 

 

Ever since then, it's been working great. I think it was a communication security/permissions issue.

 

If I had to guess, it would work if you

Go to Wifi Direct on the phone and TV

Connect to TV from phone and allow permissions

Open Smart View, select the TV and again allow permissions 

Go back to Wifi Direct settings and disconnect from TV

Smart Things should now connect with no problems. 

 

I wish you luck.

Highlighted

I was having the same trouble and following this forum. :thumbs-up-sign-emoji-modifier-fitzpatrick-type:

In the end I havent reset any connections or wifi and simply selected screen monitoring on my TV options (Smart Sony TV) and Smart View on my phone at the same time. On previous S7, just needed to select smart view, but seems need to select on TV too with S9. Works fine now, great piece of software. Hope this helps some people. :hand-with-index-and-middle-fingers-crossed:

Highlighted
First Poster

i unable to connect my samsung s9 plus to my tv smart view .

Highlighted

Have you tried these steps?

 

Open Smart Things > choose your TV > then hit the menu button ( the three dots) and finally select mirror screen ( smart view). 

Highlighted

Also here i got my s9+ before 2 days and i can’t share my s9+ screen to my lg smart tv the model# for my tv is 55UJ634V.

Highlighted

 i have the same problem 

s9+ doesnt connect zu all my samsung smarttv.

 

s6 s7 ans s8 no probs 

I found the solution for this problem. There is 2 reasons behind this. First reason from vpn connection at your mobile. Just disconnect vpn and it will work. If not then the problem from TV itself having limited connection with mobiles through mirroring feature. To fix this iusse just reset factory settings for TV. I hope this helps you. Enjoy 😊

Highlighted

Hey ya'll I just had an interesting time trying to pair my S9 to my new TV, and for some reason on the phone in "settings" - -> "connections" - - > "More connection settings" - - > "Nearby Device Scanning" was not turned on. I've never seen that setting before, so I hope this might help someone like me who doesn't know it exists yet. I feel silly after spending an hour scratching my head and in chats with clueless support people and trying different remote apps lol. Obviously if the phone cant be searched for by nearby devices or search for the TV, then it can't connect. Also, like the TV says, you need to make sure it's on the same wifi. It still didn't work at first so I reset the phone and TV  then did a hard reset on my router and modem. Good Luck! 💖 😂😊📺👍

Top Liked Authors