Support

Open search

Mobile data not working after disconnection from WiFi

Highlighted
Apprentice

This fault occurred after the most recent update of my S9. When my phone disconnects from a WiFi network (whether manually or once out of range) my phone will display either a 4g or H+ but no data is sent or received and apps/browser will confirm the phone is offline. The only way I can get mobile data to work again is to either toggle it off and on or go into flight mode for a short time.

This happens on any WiFi network (home, work, public) and I have the auto WiFi switcher features tuned off. Has anyone else come across this issue? I reset my network settings but that hasn't helped. Would prefer not to have to factory reset to correct a fault which Samsung seem to have introduced themselves. 

Thanks

53 REPLIES 53
Highlighted

Latest patch works for me... VOLTE is back 

Highlighted

Unfortunately VoLTE still isn't working on my dual SIM variant. Only using a SIM in slot 1.

 

Screenshot of my current patch, at least until I checked just now:

 

Screenshot_20180810-212443_Software update.jpg

 

I just did a manual check for software update and it's currently downloading an update! Why it didn't download it automatically I don't know...

 

Screenshot_20180810-223832_Software update.jpg

 

Is this the patch your device is running? 

August patch is the latest and fixed the problem for me.

Highlighted

Yep, initial tests look good here too - data works after disabling wifi with VoLTE enabled. The data connections to the Three VoLTE endpoints don't get stuck in established state (everything reconnects properly) and calls over 4G work, happy days. Hopefully it'll continue working 🙂 thanks for pointing out the software update! 

Highlighted

Hi all. Is everything still working OK for everyone after the latest update?

Highlighted

So far so good. Not noticing anything worrying at the moment.

 

Had a slightly hairy moment when I had no signal on both my Sims at the same time when looking to pay using an app at the meter - but it may have been nothing other than a coincidence 

Highlighted

Good news, @SammyHawk! Thanks for the feedback!

Highlighted
Apprentice

I have the same problem with my Samsung Galaxy A8 Dual SIM 2018 (SM-A530F). Used in the Netherlands with local carriers.

 

I bought the phone a week ago and it came with Android Oreo patched with the july 2018 patch out of the box. I had this problem since the unboxing.

Gonna try the fix I found on https://eu.community.samsung.com/t5/Galaxy-S9-S9/Can-t-switch-from-Wifi-to-Mobile-data-automatically... and see if it helps.

For me however the settings are not under the dialpad settings. For me they are under:

Setttings --> Connections --> Mobile Networks --> VoLTE calls <sim card name> 

I have disabled the option from there. Hope this helps other users.

Highlighted

Okay, just a quick update...

 

So for my Samsung A8 2018, the fix with disabling VoLTE did not work.

 

I did find that the APN settings were incorrect...once I corrected them withe the settings the provider specified and a quick restart after that to apply the new settings everything worked correctly again :smiling-face:

Highlighted

Great to hear @butt0nfreak. Thanks for the update!

Top Liked Authors