Open search

Delayed notifications issue affecting all range of Samsung devices since at least half a year.

First Poster





Currently ALL newer flagship models are affected by delayed notification issue for at least past 6+ months,  which started happening after around may 2018. Most devices are affected such as: S7, S8, S9, Note 9 and similar.

This is related to "doze" feature of android phone, where samsung optimization whitelist options are not working correctly thus affecting almost all samsung phones.


The issue  is reproduced during following scenario:


1. User locks phone, waits around 5m

2. App sends notification (which is not marked as PRIORITY in google push services).

3. User does not get notification

4. User unlocks phone, and suddenly multiple "delayed" notifications arrive.


Multiple users has reported the issue and tried various workarounds such as:


- Disabling battery optimization for certain apps

- Disabling all battery optimization options

- Making sure "WIFI" connection is always maintaned, even during sleep mode

- Making sure DATA connection is always maintaned

- Restoring device to factory

- Totally replacing devices with new ones.

- Wiping cache and similar


There is currently only one temporarly solution working, which is disabling doze using adb console. This workaround is temporarly and works until next reboot. It requires setting phone to debug mode and connecting to it.


"adb shell dumpsys deviceidle disable"


Samsung reaction:


Samsung is totally ignoring the technical issue since at least 6 months or more. There are multiple threads all over the web about such problem existing. Examples:











The issue is making phone totally unusuable for people who rely on instant notifications, such as alerts related to financial services like declining stock rates and similar. I dont understand why such critical thing like delivering notifications in time is totally ignored by samsung. The issue is not present on any other android phones.




If you have ability to contact someone of samsung development team, please forward this thread to make sure there will be finally reaction. Please reply to this thread if you have same issue.

344 REPLIES 344
For me, turning off Bluetooth wasn't enough. I had to disconnect my phone from dynamic lock on my laptop.

@mtweisenbarger wrote:
For me, turning off Bluetooth wasn't enough. I had to disconnect my phone from dynamic lock on my laptop.

What does dynamic lockscreen have to do with the laptop ?


@Ireibe wrote:

@mtweisenbarger wrote:
For me, turning off Bluetooth wasn't enough. I had to disconnect my phone from dynamic lock on my laptop.

What does dynamic lockscreen have to do with the laptop ?

It's Windows Dynamic lock, not dynamic lockscreen. It's a windows 10 feature that uses your phone bt to determine if you're in the proximity of your laptop or not. It will lock the lockscreen of the laptop if it detect the bt isn't nearby.


OMG, you guys!  I just updated to the new UI on my S9.  Did that fix my notification issues?  The answer MAY surprise you.  SPOILER ALERT!  ... No, it did not.  :smiling-face:


Something to try if you haven't already is for some saying that they removed any permissions allowing apps to have networking level or notification access etc you must also go through which apps are allowed to change system settings as this trumps your other settings.  If you want to test properly remove those apps and see how the next couple days go.  If all is well add one app back in every couple days to find the problem app.  Device admin apps trumps everything as well so make sure there's nothing sketchy going on in there. 

New Member

Hello there!


Got my S7 2,5 years ago, used mainly for my business. The phone did work that time 3 days without charging, as I only do some stuff, like E-Banking Pins, Signal, etc.


Since some bogus firmware update, the phone is now a useless piece of wood: I dont get any Push messages any more, as described in this thread over and over again. What's the use if no Signal comes in, no BLockfolio alarm setting, etc.?


So, only workaround is the adb command, meaning: every day, the phone has to be charged. Over night, the power drains for around 15%. I can use power saving, saves me maybe 3%. So, very nice job indeed.


As I am somewhat an influencer of my nearest folks, I am in charge of around 20 phones and more of media stuff, funny thing, all Samsung. For the future, there wont be a single Samsung any more for all there folks, who rely on my professional opinion. I know, Samsung, you don't care, the world is soo big, there is customer at ever corner, but I can tell you for sure: Oneplus can get that now, not you, and you know, for how long? Forever, long time, I know, but to be honest, you did earn it honestly and well to be not bought any more. You can put sweet fm-ads into my ear about the soo cool new S20, but you know, I am death for all which sounds like sam...and ends with ...ung. Televisons, Printers, Phones, Harddrives, the whole picture, you name it. This phonen has only 2.5 years of functions and is already degraded to some useless piece of old-time-mobile.


To follow up.  I can confirm that it was a particular app likely with super permissions.  After removing many old apps and ones with super permissions it's been resolved for a while now.


how do you find the apps that have super permissions?


I started having the same issue only on  certain apps. Mainly Google Yahoo and TV news apps  All that post notifications to do with covid 19. I have pretty much tried everything short of a hammer  No matter what I do even turning off, restarting, etc. I get nothing it started a day or two ago and since then I haven't received a single notification from them but still receive notifications from my other apps. So l say what my screen name says if you reverse the first and last letters???


Totally what the fluff!?  I guess you've tried all the suggestions in this thread, @FTW ?  The only thing that works for me is the adb shell doze disable.  It's not ideal but it only takes a minute to do, since I saved a text doc with the 3 command lines I need to run for it.  Maybe your phone caught the Covid-19?  😞

Top Liked Authors